summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2018-07-15 15:47:20 +0200
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2018-07-15 15:47:20 +0200
commitbbbd1afd333277445ff41d92a5a1a37e72b992c2 (patch)
tree0df69fbbb41986bd4d115a779acab45de68f0166
parent6c049aa49101f0a94f66b86d73d90188e14bb560 (diff)
New upstream version 0.3.1
-rw-r--r--PKG-INFO2
-rw-r--r--docs/conf.py4
-rw-r--r--docs/releasenotes.rst10
-rw-r--r--pydenticon.egg-info/PKG-INFO2
-rw-r--r--pydenticon/__init__.py3
-rw-r--r--setup.py2
6 files changed, 18 insertions, 5 deletions
diff --git a/PKG-INFO b/PKG-INFO
index 8e48c91..bf7361f 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: pydenticon
-Version: 0.3
+Version: 0.3.1
Summary: Library for generating identicons. Port of Sigil (https://github.com/cupcake/sigil) with enhancements.
Home-page: https://github.com/azaghal/pydenticon
Author: Branko Majic
diff --git a/docs/conf.py b/docs/conf.py
index ac49123..90a12d3 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -49,9 +49,9 @@ copyright = u'2013, Branko Majic'
# built documents.
#
# The short X.Y version.
-version = '0.3'
+version = '0.3.1'
# The full version, including alpha/beta/rc tags.
-release = '0.3'
+release = '0.3.1'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/docs/releasenotes.rst b/docs/releasenotes.rst
index 15b5b45..3debd98 100644
--- a/docs/releasenotes.rst
+++ b/docs/releasenotes.rst
@@ -1,6 +1,16 @@
Release Notes
=============
+0.3.1
+-----
+
+Minor bug-fixes.
+
+Bug fixes:
+
+* `PYD-8 - Cannot generate identicons in JPEG format when using Pillow >= 4.2.0
+ <https://projects.majic.rs/pydenticon/issues/PYD-8>`_
+
0.3
---
diff --git a/pydenticon.egg-info/PKG-INFO b/pydenticon.egg-info/PKG-INFO
index 8e48c91..bf7361f 100644
--- a/pydenticon.egg-info/PKG-INFO
+++ b/pydenticon.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: pydenticon
-Version: 0.3
+Version: 0.3.1
Summary: Library for generating identicons. Port of Sigil (https://github.com/cupcake/sigil) with enhancements.
Home-page: https://github.com/azaghal/pydenticon
Author: Branko Majic
diff --git a/pydenticon/__init__.py b/pydenticon/__init__.py
index 0edfdb0..f499988 100644
--- a/pydenticon/__init__.py
+++ b/pydenticon/__init__.py
@@ -246,6 +246,9 @@ class Generator(object):
# Set-up a stream where image will be saved.
stream = BytesIO()
+ if image_format.upper() == "JPEG":
+ image = image.convert(mode="RGB")
+
# Save the image to stream.
try:
image.save(stream, format=image_format, optimize=True)
diff --git a/setup.py b/setup.py
index c572f75..6bc246e 100644
--- a/setup.py
+++ b/setup.py
@@ -10,7 +10,7 @@ os.chdir(os.path.normpath(os.path.join(os.path.abspath(__file__), os.pardir)))
setup(
name='pydenticon',
- version='0.3',
+ version='0.3.1',
packages=['pydenticon'],
include_package_data=True,
license='BSD', # example license