summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2017-02-12 10:34:08 +0100
committerAndrew Shadura <andrewsh@debian.org>2017-02-12 10:34:08 +0100
commitfd22e94e998ff363c2fc830973532dcdf694a5db (patch)
treed670835e884516c25025ac399379402906185bed
parenta51d3d287523d4c7562fb07bd1fe361a956ee74f (diff)
Add Python 3 package, port to pybuild.
-rw-r--r--debian/control26
-rwxr-xr-xdebian/rules5
2 files changed, 27 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index c0c103f..48a69bb 100644
--- a/debian/control
+++ b/debian/control
@@ -4,8 +4,11 @@ Section: python
Priority: optional
Build-Depends:
debhelper (>= 9),
+ dh-python,
python-all (>= 2.6.6-3),
- python-setuptools (>= 0.6b3)
+ python-setuptools (>= 0.6.24),
+ python3-all,
+ python3-setuptools (>= 0.6.24)
Standards-Version: 3.9.1
Package: python-pydenticon
@@ -13,6 +16,7 @@ Architecture: all
Depends:
${misc:Depends},
${python:Depends}
+Provides: ${python:Provides}
Description: deterministically generate identicons in Python
Pydenticon is a small utility library that can be used for deterministically
generating identicons based on the hash of provided data.
@@ -27,3 +31,23 @@ Description: deterministically generate identicons in Python
* Ability to specify a rectangle for identicon size.
.
This package is for Python 2.
+
+Package: python3-pydenticon
+Architecture: all
+Depends:
+ ${misc:Depends},
+ ${python3:Depends}
+Description: deterministically generate identicons in Python 3
+ Pydenticon is a small utility library that can be used for deterministically
+ generating identicons based on the hash of provided data.
+ .
+ The implementation is a port of the Sigil identicon implementation.
+ .
+ Pydenticon provides a couple of extensions of its own when compared to the
+ original Sigil implementation, like:
+ .
+ * Ability to supply custom digest algorithms (allowing for larger identicons if
+ digest provides enough entropy).
+ * Ability to specify a rectangle for identicon size.
+ .
+ This package is for Python 3.
diff --git a/debian/rules b/debian/rules
index dcf1279..2660e23 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,8 @@
#!/usr/bin/make -f
-# This file was automatically generated by stdeb 0.6.0+git at
-# Tue, 25 Aug 2015 10:43:55 +0100
+export PYBUILD_NAME=pydenticon
%:
- dh $@ --with python2 --buildsystem=python_distutils
+ dh $@ --with python2,python3 --buildsystem=pybuild