summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-09-07 14:33:43 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-11-26 20:26:28 +0100
commit1b7d4f4862cc3e1ab940baa4c34003d09a1c5f8c (patch)
tree2fccab2fd752b88318c2cfff5af3dad6f07f6f97
parentdb95f4723176c1d1a9195d1a25b575f67b40f739 (diff)
fix the install_requires depends
Gbp-Pq: Name 0002-fix-the-install_requires-depends.patch
-rw-r--r--setup.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ae6dc12..abe7442 100644
--- a/setup.py
+++ b/setup.py
@@ -864,7 +864,15 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy",
# for the script launcher
- "setuptools"]
+ "setuptools",
+ # for debian
+ "h5py",
+ "lxml",
+ "matplotlib",
+ "pil",
+ "PyQt5",
+ "six"
+ ]
setup_requires = ["setuptools", "numpy", "cython"]