summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-09-07 14:33:43 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-01-21 15:07:49 +0100
commit457dc1ac9ae1821d6e021e6dcfdf5d9f606c28e2 (patch)
treea94137152c38c984f755c984084b81da0517fde7
parentfabbd74b6e6ded317a6038c467778da14405ff40 (diff)
fix the install_requires depends
Gbp-Pq: Name 0002-fix-the-install_requires-depends.patch
-rw-r--r--setup.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3fbd478..6ba6e41 100644
--- a/setup.py
+++ b/setup.py
@@ -864,7 +864,15 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy",
# for the script launcher
- "setuptools"]
+ "setuptools",
+ # for debian
+ "h5py",
+ "lxml",
+ "matplotlib",
+ "pil",
+ "PyQt5",
+ "six"
+ ]
setup_requires = ["setuptools", "numpy", "cython"]