summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2017-09-07 14:33:43 +0200
committerPicca Frédéric-Emmanuel <picca@debian.org>2019-10-19 13:25:00 +0200
commitc3856b8d89d35835a7d74791f22d5d2fc43079be (patch)
tree060bb6def354d73e2a166564f8c5ddbf4dff6633
parentb80dc99d0df5c2bed9f7ee139f68a051575fa16c (diff)
fix the install_requires depends
Gbp-Pq: Name 0002-fix-the-install_requires-depends.patch
-rw-r--r--setup.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bc165cb..8b0dcb2 100644
--- a/setup.py
+++ b/setup.py
@@ -963,7 +963,15 @@ def get_project_configuration(dry_run):
# for most of the computation
"numpy%s" % numpy_requested_version,
# for the script launcher
- "setuptools"]
+ "setuptools",
+ # for debian
+ "h5py",
+ "lxml",
+ "matplotlib",
+ "pil",
+ "PyQt5",
+ "six"
+ ]
setup_requires = ["setuptools", "numpy"]