summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 618715e..ae18f18 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,7 +23,7 @@ endif
override_dh_auto_test:
# https://github.com/silx-kit/fabio/issues/153
-# PYBUILD_SYSTEM=custom \
+ PYBUILD_SYSTEM=custom \
PYBUILD_TEST_ARGS="PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' FABIO_TESTIMAGES=testimages xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} ./run_tests.py" dh_auto_test
execute_after_dh_auto_install-indep:
@@ -39,3 +39,9 @@ execute_after_dh_link:
override_dh_sphinxdoc:
dh_sphinxdoc -p python-fabio-doc -X_static/mathjax -O--buildsystem=pybuild
+
+execute_before_dh_fixperms:
+ # hack until the 1/1/1970 issue is solved by upstream
+ -find debian/fabio-viewer -type f | xargs touch -d@${SOURCE_DATE_EPOCH}
+ -find debian/python3-fabio -type f | xargs touch -d@${SOURCE_DATE_EPOCH}
+ -find debian/python-fabio-doc -type f | xargs touch -d@${SOURCE_DATE_EPOCH}