summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Tille <tille@debian.org>2020-05-02 10:08:39 +0200
committerAndreas Tille <tille@debian.org>2020-05-02 10:08:39 +0200
commitcbdef0f171a04624415e464e182ef249fe684792 (patch)
tree6d035074ff18ed60e2e444cd6b8921bf0d764f4e
parent69dce03bdf4df7b955c8f3c03d349382667ee7ec (diff)
Upstream applied several patches
-rw-r--r--debian/patches/fix-kwargs.patch38
-rw-r--r--debian/patches/fix-scikit-learn-resource-load.patch22
-rw-r--r--debian/patches/series3
-rw-r--r--debian/patches/typo-redwood.patch25
4 files changed, 0 insertions, 88 deletions
diff --git a/debian/patches/fix-kwargs.patch b/debian/patches/fix-kwargs.patch
deleted file mode 100644
index ff49ada..0000000
--- a/debian/patches/fix-kwargs.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Description: fixed a small error with kwargs
- cherry picked from upstream, fixes a crash when running the provided test
- suite:
- plotting in the following window:
- 0 <= Q-score (x-axis) <= 14.0
- 0 <= length (y-axis) <= 223383
- .
- Traceback (most recent call last):
- File "/usr/bin/pauvre", line 11, in <module>
- load_entry_point('pauvre==0.1924', 'console_scripts', 'pauvre')()
- File "/usr/lib/python3/dist-packages/pauvre/pauvre_main.py", line 630, in main
- args.func(parser, args)
- File "/usr/lib/python3/dist-packages/pauvre/pauvre_main.py", line 64, in run_subtool
- submodule.run(args)
- File "/usr/lib/python3/dist-packages/pauvre/marginplot.py", line 403, in run
- margin_plot(df=df.dropna(), **vars(args))
- File "/usr/lib/python3/dist-packages/pauvre/marginplot.py", line 381, in margin_plot
- if kwargs["BASENAME"] is None and not kwargs["path"] is None:
- KeyError: 'path'
-Origin: upstream, https://github.com/conchoecia/pauvre/commit/90fbe2f4c190ff897dfc8ae12971d5865682fc8a
-Forwarded: https://github.com/conchoecia/pauvre/commit/90fbe2f4c190ff897dfc8ae12971d5865682fc8a
-Applied-Upstream: https://github.com/conchoecia/pauvre/commit/90fbe2f4c190ff897dfc8ae12971d5865682fc8a
-Last-Update: 2020-04-28
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- python-pauvre.orig/pauvre/marginplot.py
-+++ python-pauvre/pauvre/marginplot.py
-@@ -378,9 +378,7 @@
- min_plot_qual, max_plot_qual, min_plot_length, max_plot_length),
- file=stderr)
- # Print image(s)
-- if kwargs["BASENAME"] is None and not kwargs["path"] is None:
-- file_base = kwargs["BASENAME"]
-- elif kwargs["BASENAME"] is None:
-+ if kwargs["BASENAME"] is None:
- file_base = opath.splitext(opath.basename(kwargs["fastq"]))[0]
- else:
- file_base = kwargs["BASENAME"]
diff --git a/debian/patches/fix-scikit-learn-resource-load.patch b/debian/patches/fix-scikit-learn-resource-load.patch
deleted file mode 100644
index 0cb4c6b..0000000
--- a/debian/patches/fix-scikit-learn-resource-load.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Description: require scikit-learn instead of sklearn
- This fixes a problem in pkg_resource loading when trying to start pauvre with
- the provided command line interface. See the following for more details:
- https://lists.debian.org/debian-python/2020/04/msg00146.html
- Not sure yet if this is Debian specific. If not it might be worth contacting
- upstream.
-Author: Etienne Mollier <etienne.mollier@mailoo.org>
-Forwarded: no
-Last-Update: 2020-04-27
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- python-pauvre.orig/setup.py
-+++ python-pauvre/setup.py
-@@ -65,7 +65,7 @@
- "pandas >= 0.20.1",
- "numpy >= 1.12.1",
- "scipy",
-- "sklearn"
-+ "scikit-learn"
- ],
- entry_points={
- 'console_scripts': ['pauvre=pauvre.pauvre_main:main'],
diff --git a/debian/patches/series b/debian/patches/series
index 7421171..c1f6c9b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,5 +1,2 @@
-fix-scikit-learn-resource-load.patch
2to3.patch
-typo-redwood.patch
lsi-test-args.patch
-fix-kwargs.patch
diff --git a/debian/patches/typo-redwood.patch b/debian/patches/typo-redwood.patch
deleted file mode 100644
index 71a33f1..0000000
--- a/debian/patches/typo-redwood.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Description: p/redwood.py: fixed what looks like a typo
- this typo issued the following message during byte-compilation:
- .
- byte-compiling /mnt/data/emollier/debian/python-pauvre/debian/python3-pauvre/usr/lib/python3.8/dist-packages/pauvre/redwood.py to redwood.cpython-38.pyc
- File "/usr/lib/python3.8/dist-packages/pauvre/redwood.py", line 706
- ifargs.BASENAME is None:
- ^
- SyntaxError: invalid syntax
-Author: Etienne Mollier <etienne.mollier@mailoo.org>
-Bug: https://github.com/conchoecia/pauvre/pull/39
-Applied-Upstream: https://github.com/conchoecia/pauvre/commit/6d55b8671b2797ae7ffeb8c8e9f2815851a4a3f8
-Last-Update: 2020-05-01
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- python-pauvre.orig/pauvre/redwood.py
-+++ python-pauvre/pauvre/redwood.py
-@@ -703,7 +703,7 @@
- end = time.time()
- print(end - start)
- # Print image(s)
-- ifargs.BASENAME is None:
-+ if args.BASENAME is None:
- file_base = "redwood"
- else:
- file_base = args.BASENAME