summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/copyright2
-rw-r--r--debian/patches/pandas-2.0.patch20
-rw-r--r--debian/patches/series1
-rw-r--r--pauvre/functions.py4
5 files changed, 31 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index d7120da..9ae1f9b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+python-pauvre (0.2.3-3) unstable; urgency=medium
+
+ * pandas-2.0.patch: new: fix ftbfs with pandas 2.0. (Closes: #1044070)
+ * d/copyright: bump packaging copyright year.
+
+ -- Étienne Mollier <emollier@debian.org> Wed, 06 Sep 2023 22:18:51 +0200
+
python-pauvre (0.2.3-2) unstable; urgency=medium
* biopython-1.80.patch: add; migrate away from Bio.SubsMat.
diff --git a/debian/copyright b/debian/copyright
index c7a3d2b..fcac93f 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -9,7 +9,7 @@ License: GPL-3+
Files: debian/*
Copyright: 2020 Andreas Tille <tille@debian.org>
2021 Nilesh Patra <nilesh@debian.org>
- 2020-2022 Étienne Mollier <emollier@debian.org>
+ 2020-2023 Étienne Mollier <emollier@debian.org>
License: GPL-3+
License: GPL-3+
diff --git a/debian/patches/pandas-2.0.patch b/debian/patches/pandas-2.0.patch
new file mode 100644
index 0000000..f04688f
--- /dev/null
+++ b/debian/patches/pandas-2.0.patch
@@ -0,0 +1,20 @@
+Description: fix test failure with pandas 2.0
+Author: Étienne Mollier <emollier@debian.org>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1044070
+Forwarded: https://github.com/conchoecia/pauvre/pull/47
+Last-Update: 2023-09-06
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- python-pauvre.orig/pauvre/functions.py
++++ python-pauvre/pauvre/functions.py
+@@ -72,8 +72,8 @@
+ self.features = pd.read_csv(self.filename, comment='#',
+ sep='\t', names=gffnames)
+ self.features['name'] = self.features['tags'].apply(self._get_name)
+- self.features.drop('dunno1', 1, inplace=True)
+- self.features.drop('dunno2', 1, inplace=True)
++ self.features.drop('dunno1', axis=1, inplace=True)
++ self.features.drop('dunno2', axis=1, inplace=True)
+ self.features.reset_index(inplace=True, drop=True)
+ # warn the user if there are CDS or gene entries not divisible by three
+ self._check_triplets()
diff --git a/debian/patches/series b/debian/patches/series
index a834f08..a3d7455 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
2to3.patch
lsi-test-args.patch
biopython-1.80.patch
+pandas-2.0.patch
diff --git a/pauvre/functions.py b/pauvre/functions.py
index c6ca2b8..d496d15 100644
--- a/pauvre/functions.py
+++ b/pauvre/functions.py
@@ -72,8 +72,8 @@ class GFFParse():
self.features = pd.read_csv(self.filename, comment='#',
sep='\t', names=gffnames)
self.features['name'] = self.features['tags'].apply(self._get_name)
- self.features.drop('dunno1', 1, inplace=True)
- self.features.drop('dunno2', 1, inplace=True)
+ self.features.drop('dunno1', axis=1, inplace=True)
+ self.features.drop('dunno2', axis=1, inplace=True)
self.features.reset_index(inplace=True, drop=True)
# warn the user if there are CDS or gene entries not divisible by three
self._check_triplets()