summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeil Williams <codehelp@debian.org>2022-02-04 09:17:20 +0000
committerNeil Williams <codehelp@debian.org>2022-02-04 09:17:20 +0000
commit6b350a400dba779e73011cb8b6b54dbf4bdab6ac (patch)
tree1326a30cabb4b9de05c704ebf54548bbeb329425
parent2ab9d8148dfc5508599d792ccd2ff198d9a3d6a7 (diff)
Explicitly add epics-base B-D to d.control
Add autopkgtest correction. Tidy up d.copyright
-rw-r--r--debian/README.Debian12
-rw-r--r--debian/control16
-rw-r--r--debian/copyright2
-rw-r--r--debian/tests/control2
-rwxr-xr-xdebian/tests/imports6
-rwxr-xr-xdebian/tests/pv_unittest0
6 files changed, 31 insertions, 7 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..6af3d50
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,12 @@
+pyepics for Debian
+----------------
+
+The upstream INSTALL file describes importing a lib module as epics.
+The Debian packaging creates the 'epics' module, so import that directly.
+
+Instead of:
+ import lib as epics
+use:
+ import epics
+
+ -- Neil Williams <codehelp@debian.org> Mon, 31 Jan 2022 10:46:27 +0000
diff --git a/debian/control b/debian/control
index 5a4d783..3659636 100644
--- a/debian/control
+++ b/debian/control
@@ -9,6 +9,7 @@ Uploaders:
Build-Depends:
debhelper-compat (= 13),
libca-dev,
+ libcom-dev,
dh-python,
python3-all:any,
python3-numpy,
@@ -26,11 +27,16 @@ Vcs-Git: https://salsa.debian.org/science-team/python-pyepics.git
Package: python3-pyepics
Architecture: all
-Depends: ${python3:Depends}, ${misc:Depends}, python3-pkg-resources
+Depends:
+ ${python3:Depends},
+ ${misc:Depends},
+ python3-pkg-resources,
+ libca4.13.5,
+ libcom3.17.6
Suggests: python-pyepics-doc
Description: EPICS channel access for Python
- PyEpics is a Python interface to the EPICS Channel Access (CA) library
- for the EPICS control system.
+ PyEpics3 is a Python interface to the EPICS Channel Access (CA) library
+ for the Experimental Physics and Industrial Control System (EPICS).
.
The PyEpics module includes both low-level (C-like) and higher-level access
(with Python objects) to the EPICS Channel Access (CA) protocol. Python's
@@ -47,7 +53,7 @@ Section: doc
Depends: ${sphinxdoc:Depends}, ${misc:Depends}
Description: EPICS channel access for Python (common documentation)
PyEpics is a Python interface to the EPICS Channel Access (CA) library
- for the EPICS control system.
+ for the Experimental Physics and Industrial Control System (EPICS).
.
The PyEpics module includes both low-level (C-like) and higher-level access
(with Python objects) to the EPICS Channel Access (CA) protocol. Python's
@@ -56,4 +62,4 @@ Description: EPICS channel access for Python (common documentation)
advantages including no need for extension code written in C, better
thread-safety, and easier installation on multiple platforms.
.
- This is the common documentation package.
+ This is the PyEpics3 documentation package.
diff --git a/debian/copyright b/debian/copyright
index 95bddf2..de4b57a 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -17,8 +17,6 @@ Files: epics/devices/ordereddict.py epics/wx/ordereddict.py
Copyright: 2009 Raymond Hettinger
License: BSD-2
-# If you want to use GPL v2 or later for the /debian/* files use
-# the following clauses, or change it to suit. Delete these two lines
Files: debian/*
Copyright: 2020-2021, Andrius Merkys <merkys@debian.org>; 2021 Sebastien Delafond <seb@debian.org>
License: GPL-2+
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..c568a2f
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,2 @@
+Tests: imports pv_unittest
+Depends: @
diff --git a/debian/tests/imports b/debian/tests/imports
new file mode 100755
index 0000000..fa8e4ff
--- /dev/null
+++ b/debian/tests/imports
@@ -0,0 +1,6 @@
+#!/usr/bin/python3
+
+import epics
+
+epics.ca.find_libca()
+
diff --git a/debian/tests/pv_unittest b/debian/tests/pv_unittest
new file mode 100755
index 0000000..e69de29
--- /dev/null
+++ b/debian/tests/pv_unittest