summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott Talbert <swt@techie.net>2022-02-19 15:57:28 -0500
committerScott Talbert <swt@techie.net>2022-02-19 16:11:27 -0500
commit194a069a0a4867ebe11fe31e03eb35e8c99e16af (patch)
tree5700eefb2bf5a2002c38dfa45b58b85007c2188b
parentb4aae3fd73ea8d66d779e5b0649803034cd6abdd (diff)
Enable unittests at build time
-rw-r--r--debian/changelog4
-rw-r--r--debian/control2
-rw-r--r--debian/pybuild.testfiles2
-rwxr-xr-xdebian/rules4
4 files changed, 8 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 0cca684..588b8bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,11 @@
python-pytest-flake8 (1.0.6-4) UNRELEASED; urgency=medium
+ [ Debian Janitor ]
* Update standards version to 4.5.1, no changes needed.
+ [ Scott Talbert ]
+ * Enable unittests at build time
+
-- Debian Janitor <janitor@jelmer.uk> Wed, 25 Aug 2021 18:01:32 -0000
python-pytest-flake8 (1.0.6-3) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index fb86817..046b1c0 100644
--- a/debian/control
+++ b/debian/control
@@ -5,6 +5,8 @@ Maintainer: Debian Python Team <team+python@tracker.debian.org>
Uploaders: Sergio Durigan Junior <sergiodj@debian.org>
Build-Depends: debhelper-compat (= 13),
dh-python,
+ python3-flake8 <!nocheck>,
+ python3-pytest <!nocheck>,
python3-setuptools,
python3-all,
Standards-Version: 4.5.1
diff --git a/debian/pybuild.testfiles b/debian/pybuild.testfiles
new file mode 100644
index 0000000..e04fab7
--- /dev/null
+++ b/debian/pybuild.testfiles
@@ -0,0 +1,2 @@
+pytest_flake8.egg-info
+test_flake8.py
diff --git a/debian/rules b/debian/rules
index cb77f9a..5da2224 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,7 +4,3 @@ export PYBUILD_NAME=python-pytest-flake8
%:
dh $@ --with python3 --buildsystem=pybuild
-
-# Disable tests during build time because they're too complex to run.
-# Instead, let's just use autopkgtest.
-override_dh_auto_test: