summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott Talbert <swt@techie.net>2022-02-19 16:43:01 -0500
committerScott Talbert <swt@techie.net>2022-02-19 16:43:01 -0500
commit7697c1e2ce0c4755e3973795852e4ff40d28ddb4 (patch)
tree855d7f535ca0afe9439f1cc1d4181fe2b1bcf383
parent7b048daeb2d65dce2419dd4103903ac0d790ce34 (diff)
Run CI tests on all supported Python versions
-rw-r--r--debian/changelog1
-rw-r--r--debian/tests/control1
-rw-r--r--debian/tests/upstream2
3 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 05cdda7..99419f8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ python-pytest-flake8 (1.0.6-4) UNRELEASED; urgency=medium
[ Scott Talbert ]
* Enable unittests at build time
* Support python3-flake8 >= 4.x
+ * Run CI tests on all supported Python versions
-- Debian Janitor <janitor@jelmer.uk> Wed, 25 Aug 2021 18:01:32 -0000
diff --git a/debian/tests/control b/debian/tests/control
index ca7d93a..1ba6177 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,4 +1,5 @@
Tests: upstream
Depends: @,
+ python3-all,
python3-pytest,
python3-flake8,
diff --git a/debian/tests/upstream b/debian/tests/upstream
index 6d7550f..d654e41 100644
--- a/debian/tests/upstream
+++ b/debian/tests/upstream
@@ -5,4 +5,4 @@ set -e
cp tox.ini $AUTOPKGTEST_TMP
cp test_flake8.py $AUTOPKGTEST_TMP
cd $AUTOPKGTEST_TMP
-python3 -m pytest
+for py in $(py3versions -s); do $py -m pytest -v; done