summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergio Durigan Junior <sergiodj@sergiodj.net>2020-09-06 20:21:46 -0400
committerSergio Durigan Junior <sergiodj@sergiodj.net>2020-09-06 20:42:27 -0400
commitef4e6002a32076118da02752aa1310bec6ba9495 (patch)
tree43fde073eda7f133ec7596d9bdabbff9540b6201
parent80db78517e907322b9d7ad4ec6c93933052a7488 (diff)
Debianize the package.
-rw-r--r--debian/changelog5
-rw-r--r--debian/control24
-rw-r--r--debian/copyright34
-rwxr-xr-xdebian/rules10
-rw-r--r--debian/salsa-ci.yml11
-rw-r--r--debian/source/format1
-rw-r--r--debian/source/options1
-rw-r--r--debian/tests/control4
-rw-r--r--debian/tests/upstream8
-rw-r--r--debian/watch3
10 files changed, 101 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..1a97fe7
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+python-pytest-flake8 (1.0.6-1) unstable; urgency=medium
+
+ * Initial release (Closes: #894786).
+
+ -- Sergio Durigan Junior <sergiodj@debian.org> Sun, 06 Sep 2020 17:05:20 -0400
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..6cd5723
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,24 @@
+Source: python-pytest-flake8
+Section: python
+Priority: optional
+Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
+Uploaders: Sergio Durigan Junior <sergiodj@debian.org>
+Build-Depends: debhelper-compat (= 13),
+ dh-python,
+ python3-setuptools,
+ python3-all,
+Standards-Version: 4.5.0
+Homepage: https://github.com/tholo/pytest-flake8
+Vcs-Browser: https://salsa.debian.org/python-team/modules/python-pytest-flake8
+Vcs-Git: https://salsa.debian.org/python-team/modules/python-pytest-flake8.git
+Rules-Requires-Root: no
+
+Package: python3-pytest-flake8
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: Pytest plugin for check flake8 requirements (Python 3)
+ python-pytest-flake8 is a pytest plugin used to check flake8
+ requirements. After installing it, you can run pytest using the
+ "--flake8" option.
+ .
+ This package installs the library for Python 3.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..b1885d9
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,34 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: pytest-flake8
+Upstream-Contact: Thorsten Lockert <tholo@sigmasoft.com>
+Source: https://github.com/tholo/pytest-flake8
+
+Files: *
+Copyright: 2015 Thorsten Lockert <tholo@sigmasoft.com>
+License: BSD-2-Clause
+
+Files: debian/*
+Copyright: 2020 Sergio Durigan Junior <sergiodj@debian.org>
+License: BSD-2-clause
+
+License: BSD-2-clause
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions are met:
+ .
+ 1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+ .
+ 2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+ WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+ DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+ FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+ SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+ CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+ OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..cb77f9a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=python-pytest-flake8
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+# Disable tests during build time because they're too complex to run.
+# Instead, let's just use autopkgtest.
+override_dh_auto_test:
diff --git a/debian/salsa-ci.yml b/debian/salsa-ci.yml
new file mode 100644
index 0000000..260ebbe
--- /dev/null
+++ b/debian/salsa-ci.yml
@@ -0,0 +1,11 @@
+# For more information on what jobs are run see:
+# https://salsa.debian.org/salsa-ci-team/pipeline
+#
+# To enable the jobs, go to your repository (at salsa.debian.org)
+# and click over Settings > CI/CD > Expand (in General pipelines).
+# In "Custom CI config path" write debian/salsa-ci.yml and click
+# in "Save Changes". The CI tests will run after the next commit.
+---
+include:
+ - https://salsa.debian.org/salsa-ci-team/pipeline/raw/master/salsa-ci.yml
+ - https://salsa.debian.org/salsa-ci-team/pipeline/raw/master/pipeline-jobs.yml
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/source/options b/debian/source/options
new file mode 100644
index 0000000..cb61fa5
--- /dev/null
+++ b/debian/source/options
@@ -0,0 +1 @@
+extend-diff-ignore = "^[^/]*[.]egg-info/"
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..ca7d93a
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,4 @@
+Tests: upstream
+Depends: @,
+ python3-pytest,
+ python3-flake8,
diff --git a/debian/tests/upstream b/debian/tests/upstream
new file mode 100644
index 0000000..6d7550f
--- /dev/null
+++ b/debian/tests/upstream
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+set -e
+
+cp tox.ini $AUTOPKGTEST_TMP
+cp test_flake8.py $AUTOPKGTEST_TMP
+cd $AUTOPKGTEST_TMP
+python3 -m pytest
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..6d5e474
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,3 @@
+version=4
+opts=uversionmangle=s/(rc|a|b|c)/~$1/ \
+ https://pypi.debian.net/pytest-flake8/pytest-flake8-@ANY_VERSION@@ARCHIVE_EXT@