summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYOKOTA Hiroshi <yokota.hgml@gmail.com>2023-12-25 10:49:12 +0900
committerYOKOTA Hiroshi <yokota.hgml@gmail.com>2024-04-30 15:07:28 +0900
commit32c340e273801bc3155f188a6cf157436f81d085 (patch)
tree19675a515d7adbca465574440226cd32ac8c9c93
parent908a0328702d338fabb64996e84301b3964d2871 (diff)
Disable vendor specific optimization options
Forwarded: not-needed Debian packaging wants debug symbols for dbgsym packages. Gbp-Pq: Name 0001-Disable-vendor-specific-optimization-options.patch
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a85ceba..81fc9d2 100644
--- a/setup.py
+++ b/setup.py
@@ -61,7 +61,7 @@ class pyzstd_build_ext(build_ext):
self.debug = self.PYZSTD_DEBUG
for extension in self.extensions:
- if self.compiler.compiler_type in ('unix', 'mingw32', 'cygwin'):
+ if self.compiler.compiler_type in ('mingw32', 'cygwin'):
# -g0:
# Level 0 produces no debug information at all. This reduces
# the size of GCC wheels. By default CPython won't print any