summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@debian.org>2023-10-19 23:14:25 +0300
committerPeter Pentchev <roam@debian.org>2023-10-19 23:14:25 +0300
commit05595ab1e456951f333033b6f8bd7f08a0c2e16b (patch)
tree6c3de40553fd22e31a24f4bf6a7619c6a479cc4f
parentae0fb1fb9f53b5191c6bafb75a785e828ba3a0f2 (diff)
Update to version 1 of the dpkg build API
Drop the implied R-R-R: no declaration. Include dpkg's default.mk for completeness.
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules2
3 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 0c10cb7..86663fc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+python-test-stages (0.1.2-2) UNRELEASED; urgency=medium
+
+ * Update the build infrastructure to version 1 of the dpkg build API:
+ - drop the implied "Rules-Requires-Root: no" declaration
+ - include default.mk for completeness
+
+ -- Peter Pentchev <roam@debian.org> Thu, 19 Oct 2023 23:12:13 +0300
+
python-test-stages (0.1.2-1) unstable; urgency=medium
* Do not look for an OpenPGP signature on PyPI.
diff --git a/debian/control b/debian/control
index cbb6ba7..454783a 100644
--- a/debian/control
+++ b/debian/control
@@ -6,6 +6,7 @@ Uploaders: Peter Pentchev <roam@debian.org>
Build-Depends:
debhelper-compat (= 13),
dh-sequence-python3,
+ dpkg-build-api (= 1),
pybuild-plugin-pyproject,
python3-all,
python3-click (>> 8),
@@ -18,7 +19,6 @@ Build-Depends:
python3-utf8-locale (>> 1),
Standards-Version: 4.6.2
Homepage: https://gitlab.com/ppentchev/test-stages
-Rules-Requires-Root: no
Vcs-Git: https://salsa.debian.org/python-team/packages/test-stages.git
Vcs-Browser: https://salsa.debian.org/python-team/packages/test-stages
diff --git a/debian/rules b/debian/rules
index c1f2ae0..e70ffb1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,8 @@
export PYBUILD_NAME=test_stages
+include /usr/share/dpkg/default.mk
+
D= $(CURDIR)/debian
%: