summaryrefslogtreecommitdiff
path: root/config/ruff-base/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'config/ruff-base/pyproject.toml')
-rw-r--r--config/ruff-base/pyproject.toml16
1 files changed, 6 insertions, 10 deletions
diff --git a/config/ruff-base/pyproject.toml b/config/ruff-base/pyproject.toml
index bd952ab..f3db562 100644
--- a/config/ruff-base/pyproject.toml
+++ b/config/ruff-base/pyproject.toml
@@ -4,14 +4,10 @@
[tool.ruff]
target-version = "py38"
line-length = 100
+
+[tool.ruff.lint]
select = []
ignore = [
- # We know what "self" is... I hope
- "ANN101",
-
- # We let the "black" tool take care of most of the formatting
- "COM812",
-
# No blank lines before the class docstring, TYVM
"D203",
@@ -19,16 +15,16 @@ ignore = [
"D213",
]
-[tool.ruff.flake8-copyright]
+[tool.ruff.lint.flake8-copyright]
notice-rgx = "(?x) SPDX-FileCopyrightText: \\s \\S"
-[tool.ruff.isort]
+[tool.ruff.lint.isort]
force-single-line = true
known-first-party = ["test_stages", "tox_trivtags"]
lines-after-imports = 2
single-line-exclusions = ["collections.abc", "typing"]
-[tool.ruff.per-file-ignores]
+[tool.ruff.lint.per-file-ignores]
# The self-test tool uses subprocess responsibly.
"src/selftest/__main__.py" = ["S404", "S603", "S607"]
@@ -38,4 +34,4 @@ single-line-exclusions = ["collections.abc", "typing"]
# This is a unit test suite, it can output diagnostic messages.
# Also, we try to use subprocess responsibly.
-"unit_tests/**.py" = ["S101", "S404", "S603", "S607", "T201"]
+"tests/unit/**.py" = ["S101", "S404", "S603", "S607", "T201"]