summaryrefslogtreecommitdiff
path: root/nix/python-vetox.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/python-vetox.nix')
-rw-r--r--nix/python-vetox.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/nix/python-vetox.nix b/nix/python-vetox.nix
new file mode 100644
index 0000000..9b1b648
--- /dev/null
+++ b/nix/python-vetox.nix
@@ -0,0 +1,21 @@
+# SPDX-FileCopyrightText: Peter Pentchev <roam@ringlet.net>
+# SPDX-License-Identifier: BSD-2-Clause
+
+{ pkgs ? import <nixpkgs> { }
+, py-ver ? 311
+}:
+let
+ python-name = "python${toString py-ver}";
+ python = builtins.getAttr python-name pkgs;
+in
+pkgs.mkShell {
+ buildInputs = [
+ pkgs.gitMinimal
+ python
+ ];
+ shellHook = ''
+ set -e
+ python3 tests/vetox.py run-parallel
+ exit
+ '';
+}