summaryrefslogtreecommitdiff
path: root/nix/run-vetox.sh
diff options
context:
space:
mode:
Diffstat (limited to 'nix/run-vetox.sh')
-rwxr-xr-xnix/run-vetox.sh17
1 files changed, 17 insertions, 0 deletions
diff --git a/nix/run-vetox.sh b/nix/run-vetox.sh
new file mode 100755
index 0000000..6b4d93e
--- /dev/null
+++ b/nix/run-vetox.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# SPDX-FileCopyrightText: Peter Pentchev <roam@ringlet.net>
+# SPDX-License-Identifier: BSD-2-Clause
+
+set -e
+
+: "${PY_MINVER_MIN:=8}"
+: "${PY_MINVER_MAX:=13}"
+
+for minor in $(seq -- "$PY_MINVER_MIN" "$PY_MINVER_MAX"); do
+ pyver="3$minor"
+ nix/cleanpy.sh
+ printf -- '\n===== Running tests for %s\n\n\n' "$pyver"
+ nix-shell --pure --arg py-ver "$pyver" nix/python-vetox.nix
+ printf -- '\n===== Done with %s\n\n' "$pyver"
+done