summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2023-12-31 12:38:49 +0000
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2023-12-31 12:38:49 +0000
commit299ffcee7b94369d5b28f0ae18b3ea559cd8e3e3 (patch)
tree7632cefd95f281d676d20c9fd9b07db1fbb5ce56
parenta978f6ae04513387ca2fb3766887120ed3bf46c7 (diff)
Drop alternatives which existed for Python 2 co-installability
-rw-r--r--debian/python3-wheezy.template.postinst10
-rw-r--r--debian/python3-wheezy.template.preinst (renamed from debian/python3-wheezy.template.prerm)2
-rwxr-xr-xdebian/rules7
3 files changed, 1 insertions, 18 deletions
diff --git a/debian/python3-wheezy.template.postinst b/debian/python3-wheezy.template.postinst
deleted file mode 100644
index 329331f..0000000
--- a/debian/python3-wheezy.template.postinst
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-set -e
-
-if [ "$1" = "configure" ]
-then
- update-alternatives --install /usr/bin/wheezy.template wheezy.template /usr/bin/wheezy.template-python3 300
-fi
-
-#DEBHELPER#
diff --git a/debian/python3-wheezy.template.prerm b/debian/python3-wheezy.template.preinst
index 94590e1..cc7fba4 100644
--- a/debian/python3-wheezy.template.prerm
+++ b/debian/python3-wheezy.template.preinst
@@ -1,7 +1,7 @@
#!/bin/sh
set -e
-if [ "$1" = "remove" ]
+if [ "$1" = upgrade ]
then
update-alternatives --remove wheezy.template /usr/bin/wheezy.template-python3
fi
diff --git a/debian/rules b/debian/rules
index e297ca9..d690fc9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,10 +6,3 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@ --buildsystem=pybuild
-
-override_dh_auto_install:
- dh_auto_install
- mv debian/python3-$(PYBUILD_NAME)/usr/bin/$(PYBUILD_NAME) debian/python3-$(PYBUILD_NAME)/usr/bin/$(PYBUILD_NAME)-python3
- sed -i '1s,.*,#!/usr/bin/python3,' debian/python3-$(PYBUILD_NAME)/usr/bin/$(PYBUILD_NAME)-python3
-
-.PHONY: override_dh_auto_install