summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml25
1 files changed, 25 insertions, 0 deletions
diff --git a/appveyor.yml b/appveyor.yml
new file mode 100644
index 0000000..7fa81b8
--- /dev/null
+++ b/appveyor.yml
@@ -0,0 +1,25 @@
+environment:
+ matrix:
+ - TARGET: "Python 3.5"
+ PYTHON: "C:\\Python35"
+ PYTHON_VERSION: "3.5"
+ - TARGET: "Python 3.6"
+ PYTHON: "C:\\Python36"
+ PYTHON_VERSION: "3.6"
+ - TARGET: "Python 3.7"
+ PYTHON: "C:\\Python37"
+ PYTHON_VERSION: "3.7"
+ - TARGET: "Python 3.8"
+ PYTHON: "C:\\Python38"
+ PYTHON_VERSION: "3.8"
+
+install:
+ - cmd: '"C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x86 /release'
+
+build_script:
+ - "%PYTHON%\\python.exe setup.py update"
+ - "%PYTHON%\\python.exe setup.py build"
+
+test_script:
+ - "set PYTHONPATH=build\\lib.win32-%PYTHON_VERSION%"
+ - "%PYTHON%\\python.exe run_tests.py"