summaryrefslogtreecommitdiff
path: root/travis/run_python3.sh
diff options
context:
space:
mode:
Diffstat (limited to 'travis/run_python3.sh')
-rwxr-xr-xtravis/run_python3.sh19
1 files changed, 19 insertions, 0 deletions
diff --git a/travis/run_python3.sh b/travis/run_python3.sh
new file mode 100755
index 0000000..4b8fdc7
--- /dev/null
+++ b/travis/run_python3.sh
@@ -0,0 +1,19 @@
+#!/bin/bash
+#
+# Script to run Python 3 tests on Travis-CI.
+#
+# This file is generated by l2tdevtools update-dependencies.py, any dependency
+# related changes should be made in dependencies.ini.
+
+# Exit on error.
+set -e;
+
+python3 setup.py update
+
+python3 setup.py build
+
+PYTHONPATH=`ls -1d build/lib.*` python3 run_tests.py
+
+python3 setup.py sdist
+
+python3 setup.py bdist