summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDebian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>2023-01-24 19:12:56 +0100
committerAndreas Tille <tille@debian.org>2023-01-24 19:12:56 +0100
commite027d7ac582b8a8705dca829f81591474845ecf3 (patch)
tree8f20237d0e76d5258b90bfb4c90c6cd860813edc
parent8587e4f6fce49ed9a4325c62a4e934367e322207 (diff)
python2 to python3 patch
Forwarded: yes =================================================================== Gbp-Pq: Name py2to3test.patch
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 94bf97a..ae37ebb 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
.PHONY: all lint test test-cov install dev clean distclean
-PYTHON ?= python
+PYTHON ?= python3
+DESTDIR ?= $(CURDIR)/debian/q2-sample-classifier/
all: ;
@@ -9,13 +10,13 @@ lint:
flake8
test: all
- py.test
+ py.test-3
test-cov: all
- py.test --cov=q2_sample_classifier
+ py.test-3 --cov=q2_sample_classifier
install:
- $(PYTHON) setup.py install
+ $(PYTHON) setup.py install --root $(DESTDIR) --prefix=/usr --install-platlib=/usr/lib/python3/dist-packages
dev: all
pip install -e .