summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2015-02-20 00:00:00 +0100
committerRuben Undheim <ruben.undheim@gmail.com>2018-09-22 12:13:19 +0200
commit264d95743453c05c8fb6717dc453646c118d7cba (patch)
treedb5ffd3d9f730afcd44675cd246a9e19983c504a
parentc05d15c540206d28789865d5c5f73b913095e5de (diff)
Use tkon from debian
This patch makes sure that the tkcon version from debian is used instead of the version bundled with the source of qrouter. =================================================================== Gbp-Pq: Name 02_use_tkcon_from_debian.patch
-rw-r--r--Makefile.in1
-rwxr-xr-xqrouter.sh.in2
2 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 7586e15..a7b68ba 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -111,7 +111,6 @@ install-tcl: qrouter.sh qrouter.tcl qrouter$(SHDLIB_EXT) \
$(INSTALL) qrouterexec$(EXEEXT) $(DESTDIR)${LIBINSTALL}
$(INSTALL) qrouternullg$(EXEEXT) $(DESTDIR)${LIBINSTALL}
$(INSTALL) -m 0644 console.tcl $(DESTDIR)${LIBINSTALL}
- $(INSTALL) tkcon.tcl $(DESTDIR)${LIBINSTALL}
$(INSTALL) -m 0644 qrouter.tcl $(DESTDIR)${LIBINSTALL}
uninstall:
diff --git a/qrouter.sh.in b/qrouter.sh.in
index 12bab42..8e7cbda 100755
--- a/qrouter.sh.in
+++ b/qrouter.sh.in
@@ -57,7 +57,7 @@ shift
if [ $TKCON ]; then
- exec ${loclibdir}/tkcon.tcl \
+ exec /usr/bin/tkcon \
-eval "source ${loclibdir}/console.tcl" \
-slave "package require Tk; set argc $#; set argv [list $*]; \
source ${loclibdir}/qrouter.tcl"