summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2015-02-20 00:00:00 +0100
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-18 18:44:37 +0200
commitd593293ef7da8aed9701ffdc0c1342068bbba681 (patch)
tree77e156eb5ad90481ab6f71796a8fd7230a1700d4
parente06949f6f0bd8cd34fb4d4bd8690eedcfc5622fc (diff)
Use tkon from debian
This patch makes sure that the tkcon version from debian is used instead of the version bundled with the source of qrouter. =================================================================== Gbp-Pq: Name 02_use_tkcon_from_debian.patch
-rw-r--r--Makefile.in1
-rwxr-xr-xqrouter.sh.in2
2 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 7586e15..a7b68ba 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -111,7 +111,6 @@ install-tcl: qrouter.sh qrouter.tcl qrouter$(SHDLIB_EXT) \
$(INSTALL) qrouterexec$(EXEEXT) $(DESTDIR)${LIBINSTALL}
$(INSTALL) qrouternullg$(EXEEXT) $(DESTDIR)${LIBINSTALL}
$(INSTALL) -m 0644 console.tcl $(DESTDIR)${LIBINSTALL}
- $(INSTALL) tkcon.tcl $(DESTDIR)${LIBINSTALL}
$(INSTALL) -m 0644 qrouter.tcl $(DESTDIR)${LIBINSTALL}
uninstall:
diff --git a/qrouter.sh.in b/qrouter.sh.in
index 12bab42..8e7cbda 100755
--- a/qrouter.sh.in
+++ b/qrouter.sh.in
@@ -57,7 +57,7 @@ shift
if [ $TKCON ]; then
- exec ${loclibdir}/tkcon.tcl \
+ exec /usr/bin/tkcon \
-eval "source ${loclibdir}/console.tcl" \
-slave "package require Tk; set argc $#; set argv [list $*]; \
source ${loclibdir}/qrouter.tcl"