summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Tille <tille@debian.org>2021-09-09 08:01:13 +0200
committerAndreas Tille <tille@debian.org>2021-09-09 08:01:13 +0200
commitbfae2823a9ac6672748c3e9d405fa0558896f44a (patch)
tree5834c881a66233c690ac0f366341b42e337170ae
parent28c8dfb9efed208e5ee58fb9525e9f10d008f265 (diff)
Use Debian packaged samtools
Last-Update: Fri, 09 Dec 2016 14:26:08 +0100 Gbp-Pq: Name use_debian_packaged_samtools.patch
-rw-r--r--Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/Makefile b/Makefile
index 89a1773..f22af25 100644
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,7 @@ BOOST = .
# Compilation variables
CXX = g++
-CXXFLAGS += -std=gnu++98 -Wall -I. -I$(BOOST) -I$(SAMTOOLS)/$(HTSLIB)
+CXXFLAGS += -std=gnu++98 -Wall -I. -I$(BOOST)
CPPFLAGS ?=
LDFLAGS ?=
@@ -30,8 +30,8 @@ exec_prefix = $(prefix)
bindir = $(exec_prefix)/bin
# Auxiliary variables for compilation
-SAMHEADERS = $(SAMTOOLS)/$(HTSLIB)/htslib/sam.h
-SAMLIBS = $(SAMTOOLS)/$(HTSLIB)/libhts.a
+SAMHEADERS =
+SAMLIBS =
CONFIGURE = ./configure
OBJS1 = parseIt.o
@@ -54,12 +54,12 @@ SCRIPTS = rsem-prepare-reference rsem-calculate-expression rsem-refseq-extract-p
.PHONY : all ebseq pRSEM clean
-all : $(PROGRAMS) $(SAMTOOLS)/samtools
+all : $(PROGRAMS)
$(SAMTOOLS)/samtools :
cd $(SAMTOOLS) && $(CONFIGURE) --without-curses && $(MAKE) -f $(SAMTOOLS_MAKEFILE) samtools
-$(SAMLIBS) : $(SAMTOOLS)/samtools
+$(SAMLIBS) :
# Compile objects
@@ -78,10 +78,10 @@ $(PROGS1) :
$(CXX) $(LDFLAGS) -o $@ $^ $(LDLIBS)
$(PROGS2) :
- $(CXX) $(LDFLAGS) -pthread -o $@ $^ $(LDLIBS) -lz
+ $(CXX) $(LDFLAGS) -pthread -o $@ $^ $(LDLIBS) -lhts -lz
$(PROGS3) :
- $(CXX) $(LDFLAGS) -pthread -o $@ $^ $(LDLIBS)
+ $(CXX) $(LDFLAGS) -pthread -o $@ $^ $(LDLIBS) -lhts
# Dependencies for executables
@@ -163,17 +163,13 @@ pRSEM :
# Install RSEM
-install : $(PROGRAMS) $(SCRIPTS) $(SAMTOOLS)/samtools rsem_perl_utils.pm
- $(INSTALL_DIR) $(DESTDIR)$(bindir) $(DESTDIR)$(bindir)/$(SAMTOOLS)
- $(foreach prog,$(PROGRAMS),$(INSTALL_PROGRAM) $(prog) $(DESTDIR)$(bindir)/$(prog) ; $(STRIP) $(DESTDIR)$(bindir)/$(prog) ;)
- $(INSTALL_PROGRAM) $(SAMTOOLS)/samtools $(DESTDIR)$(bindir)/$(SAMTOOLS)/samtools
- $(STRIP) $(DESTDIR)$(bindir)/$(SAMTOOLS)/samtools
+install : $(PROGRAMS) $(SCRIPTS) rsem_perl_utils.pm
+ $(foreach prog,$(PROGRAMS),$(INSTALL_PROGRAM) $(prog) $(DESTDIR)$(bindir)/$(prog) ; )
$(foreach script,$(SCRIPTS),$(INSTALL_PROGRAM) $(script) $(DESTDIR)$(bindir)/$(script) ;)
$(INSTALL_DATA) rsem_perl_utils.pm $(DESTDIR)$(bindir)/rsem_perl_utils.pm
# Clean
clean :
rm -f *.o *~ $(PROGRAMS)
- cd $(SAMTOOLS) && $(MAKE) clean-all
cd EBSeq && $(MAKE) clean
cd pRSEM && $(MAKE) clean