summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorÉtienne Mollier <etienne.mollier@mailoo.org>2021-02-02 22:49:33 +0100
committerÉtienne Mollier <etienne.mollier@mailoo.org>2021-02-02 22:49:33 +0100
commit5d91a64247cff17c11c12185e156a2d0988ad74b (patch)
tree6445367694ef6b6b3da03778ad41cbed0826430c
parent5b6f5936c3f892885739dc93e071da76942b5d9f (diff)
Fix FTBFS with gcc-10.
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/gcc-10.patch37
-rw-r--r--debian/patches/series1
3 files changed, 45 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index c69873d..a56bff5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+sparskit (2.0.0-4) UNRELEASED; urgency=medium
+
+ * Team upload.
+ * Fix FTBFS with gcc-10. (Closes: #957828)
+
+ -- Étienne Mollier <etienne.mollier@mailoo.org> Tue, 02 Feb 2021 22:48:22 +0100
+
sparskit (2.0.0-3) unstable; urgency=medium
* Team upload.
diff --git a/debian/patches/gcc-10.patch b/debian/patches/gcc-10.patch
new file mode 100644
index 0000000..42144ef
--- /dev/null
+++ b/debian/patches/gcc-10.patch
@@ -0,0 +1,37 @@
+Description: fix ftbfs with gcc-10
+ This fixes the argument type mismatch in the csrcsc
+ call by introducing the one dimension vector iziama of type
+ real(8), instead of an integer(4) scalar, while trying to
+ maintain compatibility with Fortran 77.
+Author: Étienne Mollier <etienne.mollier@mailoo.org>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=957828
+Forwarded: saad *at* cs *dot* umn *dot* edu
+Last-Update: 2021-02-02
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- sparskit.orig/ORDERINGS/ccn.f
++++ sparskit/ORDERINGS/ccn.f
+@@ -90,7 +90,7 @@
+ c July 1992 - Update: March 1994
+ C-----------------------------------------------------------------------
+ integer izs(nw), lpw(n), nsbloc(0:nblcmx), ia(n+1), ja(*)
+- real*8 amat(*)
++ real*8 amat(*), iziama(1)
+ logical impr
+ character*6 chsubr
+ C-----------------------------------------------------------------------
+@@ -147,10 +147,12 @@
+ * ja, ia, izs(ilpw), izs(ilpw), job)
+ ipos = 1
+ c..........We sort columns inside JA.
+- call csrcsc(n, job, ipos, amat, ja, ia, izs(iamat),
++ iziama(1) = izs(iamat)
++ call csrcsc(n, job, ipos, amat, ja, ia, iziama,
+ * izs(ijat), izs(iiat))
+- call csrcsc(n, job, ipos, izs(iamat), izs(ijat), izs(iiat),
++ call csrcsc(n, job, ipos, iziama, izs(ijat), izs(iiat),
+ * amat, ja, ia)
++ izs(iamat) = iziama(1)
+ endif
+ c.....We modify the ordering of unknowns in LPW
+ call compos(n, lpw, izs(ilpw))
diff --git a/debian/patches/series b/debian/patches/series
index 0084ac9..e9fdeb5 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
50_all_changes.diff
+gcc-10.patch