summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@ringlet.net>2023-01-07 04:39:23 +0200
committerPeter Pentchev <roam@debian.org>2023-01-07 04:39:23 +0200
commitc4b9b4e3bb702472aa650aff91dfefb779f949e9 (patch)
tree0e02bb9914956c1958e7d52aded2d4a2ad48bae2
parentdc51dab2b7cf943a7ace0cb46d8b22007323d8fd (diff)
A cleaner build for the Debian package.
Forwarded: not-needed Last-Update: 2019-12-27 Use install(1) to install programs and manual pages, thus taking care of not always stripping the debug symbols, too (leave that to debhelper) Gbp-Pq: Name debian-build.patch
-rw-r--r--spipe/Makefile9
-rw-r--r--spiped/Makefile9
2 files changed, 4 insertions, 14 deletions
diff --git a/spipe/Makefile b/spipe/Makefile
index 467ee92..203a783 100644
--- a/spipe/Makefile
+++ b/spipe/Makefile
@@ -20,16 +20,11 @@ all:
install:${PROG}
mkdir -p ${BINDIR}
- cp ${PROG} ${BINDIR}/_inst.${PROG}.$$$$_ && \
- strip ${BINDIR}/_inst.${PROG}.$$$$_ && \
- chmod 0555 ${BINDIR}/_inst.${PROG}.$$$$_ && \
- mv -f ${BINDIR}/_inst.${PROG}.$$$$_ ${BINDIR}/${PROG}
+ install -c -m 755 ${PROG} ${BINDIR}
if ! [ -z "${MAN1DIR}" ]; then \
mkdir -p ${MAN1DIR}; \
for MPAGE in ${MAN1}; do \
- cp $$MPAGE ${MAN1DIR}/_inst.$$MPAGE.$$$$_ && \
- chmod 0444 ${MAN1DIR}/_inst.$$MPAGE.$$$$_ && \
- mv -f ${MAN1DIR}/_inst.$$MPAGE.$$$$_ ${MAN1DIR}/$$MPAGE; \
+ install -c -m 644 $$MPAGE ${MAN1DIR}; \
done; \
fi
diff --git a/spiped/Makefile b/spiped/Makefile
index 85b451b..964a636 100644
--- a/spiped/Makefile
+++ b/spiped/Makefile
@@ -20,16 +20,11 @@ all:
install:${PROG}
mkdir -p ${BINDIR}
- cp ${PROG} ${BINDIR}/_inst.${PROG}.$$$$_ && \
- strip ${BINDIR}/_inst.${PROG}.$$$$_ && \
- chmod 0555 ${BINDIR}/_inst.${PROG}.$$$$_ && \
- mv -f ${BINDIR}/_inst.${PROG}.$$$$_ ${BINDIR}/${PROG}
+ install -c -m 755 ${PROG} ${BINDIR}
if ! [ -z "${MAN1DIR}" ]; then \
mkdir -p ${MAN1DIR}; \
for MPAGE in ${MAN1}; do \
- cp $$MPAGE ${MAN1DIR}/_inst.$$MPAGE.$$$$_ && \
- chmod 0444 ${MAN1DIR}/_inst.$$MPAGE.$$$$_ && \
- mv -f ${MAN1DIR}/_inst.$$MPAGE.$$$$_ ${MAN1DIR}/$$MPAGE; \
+ install -c -m 644 $$MPAGE ${MAN1DIR}; \
done; \
fi