summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid E. Wheeler <david@justatheory.com>2023-08-01 20:07:40 -0400
committerDavid E. Wheeler <david@justatheory.com>2023-08-01 20:07:40 -0400
commit2830b9fe8d74839feb8ece1ff806fbe5076019e9 (patch)
tree870db98ea0fff7328550019b6d19fb23e8ee9241
parent30e29f504056dde4257e3569f97e45a00cd7d4c8 (diff)
Increment to v1.4.1-dev
And update the release notes and remove a wayward Data::Dump
-rw-r--r--Changes2
-rw-r--r--README.md2
-rw-r--r--dist.ini2
-rw-r--r--dist/sqitch.spec2
-rw-r--r--inc/Menlo/Sqitch.pm1
-rw-r--r--po/App-Sqitch.pot2
-rw-r--r--xt/release.md17
7 files changed, 15 insertions, 13 deletions
diff --git a/Changes b/Changes
index b615c0be..6033fa3a 100644
--- a/Changes
+++ b/Changes
@@ -1,5 +1,7 @@
Revision history for Perl extension App::Sqitch
+1.4.1
+
1.4.0 2023-08-01T23:37:30Z
- Fixed Snowflake warehouse and role setup to properly quote identifiers
unless they're valid unquoted identifiers or already quoted. Thanks to
diff --git a/README.md b/README.md
index cb465fbf..4bf81e1c 100644
--- a/README.md
+++ b/README.md
@@ -1,4 +1,4 @@
-App/Sqitch version v1.4.0
+App/Sqitch version v1.4.1-dev
=========================
| Release | Coverage | Database ||
diff --git a/dist.ini b/dist.ini
index 6f61eeb4..262efdd6 100644
--- a/dist.ini
+++ b/dist.ini
@@ -2,7 +2,7 @@ name = App-Sqitch
license = MIT
copyright_holder = "iovation Inc., David E. Wheeler"
copyright_year = 2012-2023
-version = v1.4.0
+version = v1.4.1-dev
[GatherDir]
exclude_filename = dist/cpanfile
diff --git a/dist/sqitch.spec b/dist/sqitch.spec
index dc40f81d..49f292ab 100644
--- a/dist/sqitch.spec
+++ b/dist/sqitch.spec
@@ -1,5 +1,5 @@
Name: sqitch
-Version: 1.4.0
+Version: 1.4.1-dev
Release: 1%{?dist}
Summary: Sensible database change management
License: MIT
diff --git a/inc/Menlo/Sqitch.pm b/inc/Menlo/Sqitch.pm
index 9541f1d3..74b9cb5d 100644
--- a/inc/Menlo/Sqitch.pm
+++ b/inc/Menlo/Sqitch.pm
@@ -14,7 +14,6 @@ sub new {
last unless s/^\s+//;
$deps{$_} = 1;
}
- use Data::Dump; ddx \%deps; exit;
shift->SUPER::new(
@_,
_remove => [],
diff --git a/po/App-Sqitch.pot b/po/App-Sqitch.pot
index d998166b..a9633904 100644
--- a/po/App-Sqitch.pot
+++ b/po/App-Sqitch.pot
@@ -6,7 +6,7 @@
#, fuzzy
msgid ""
msgstr ""
-"Project-Id-Version: App-Sqitch v1.4.0\n"
+"Project-Id-Version: App-Sqitch v1.4.1-dev\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2023-07-30 20:02-0400\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
diff --git a/xt/release.md b/xt/release.md
index f7a4171a..e151540c 100644
--- a/xt/release.md
+++ b/xt/release.md
@@ -2,10 +2,11 @@ Releasing Sqitch
================
Notes on the steps to make a release of Sqitch. In the steps, below, examples
-use the `$VERSION` environment variable for consistency. The assumption is that
-it's set to the new version being released, e.g.,
+use the `$VERSION` and `$OLD_VERSION` environment variables for consistency. The
+assumption is that they're set to the old and new versions, respectively, e.g.,
``` sh
+export OLD_VERSION=1.3.1
export VERSION=1.4.0
```
@@ -101,7 +102,7 @@ to get it out there!
the release and that the list of Changes is nicely formatted. It should also
appear [on CPAN] a short time later.
-* Congratulations, you'e released a new version of Sqitch! Just a few changes
+* Congratulations, you've released a new version of Sqitch! Just a few changes
left to make.
Web Site
@@ -119,11 +120,11 @@ To update the Docker image, first preserve the previous release in a branch,
then make the updates.
* Create a branch for the previous release so that it can still be supported
- if necessary. For v1.1.0, for example, do this:
+ if necessary:
``` sh
- git checkout -b v1.1.0-maint
- git push origin -u v1.1.0-maint
+ git checkout -b "v$OLD_VERSION-maint"
+ git push origin -u "v$OLD_VERSION-maint"
```
* Switch back to the main branch and update it for the new version:
@@ -193,8 +194,8 @@ Update the Sqitch Homebrew tap with the new version.
```
* And that's all it takes. If you don't already have the tap with Sqitch
- installed, you can tap and install the new version with SQLite support) with
- these commands:
+ installed, you can tap and install the new version (with SQLite support)
+ with these commands:
``` sh
brew tap sqitchers/sqitch