summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@debian.org>2023-10-07 22:30:04 +0300
committerEmanuele Rocca <ema@debian.org>2023-10-08 10:26:54 +0200
commit7daba7bf3843ed68f40a2f43731827ee82e59d8c (patch)
treebf9b2d87511ec2ed438064def08252c2a94e4d46
parent3eb1dcea386b13c895825a5844b335027e02519c (diff)
configure.ac: Always call AC_CANONICAL_HOST
This is required for host_os also with --with-cpu.
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8bd79fb..2933d05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,10 +13,10 @@ fi
AC_ARG_WITH(cpu, [ --with-cpu define host cpu])
-if test -z "$with_cpu"
+AC_CANONICAL_HOST
+
+if test -n "$with_cpu"
then
- AC_CANONICAL_HOST
-else
host_cpu=$with_cpu
fi
# Checking for target cpu and setting custom configuration