summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Rocca <ema@debian.org>2023-08-24 15:37:26 +0200
committerEmanuele Rocca <ema@debian.org>2023-08-24 15:37:26 +0200
commitb7b007c23b9fb9ad188d78600e04ce3c9bf55731 (patch)
treeab67a1c1d05a118c73361dbec1aa9e55916836e0
parent38b12b6ec3ab0eb0e515d71310fed3f7fe98c284 (diff)
Commit patch queue (exported by git-debrebase)
[git-debrebase make-patches: export and commit patches]
-rw-r--r--debian/patches/0006-Include-cstdint-to-build-with-GCC-13.patch21
-rw-r--r--debian/patches/allow-to-override-build-date-with-source.patch36
-rw-r--r--debian/patches/armhf_support24
-rw-r--r--debian/patches/fix-ftcbfs.-closes-986653.patch22
-rw-r--r--debian/patches/series6
-rw-r--r--debian/patches/support_i486_builds23
-rw-r--r--debian/patches/support_i586_builds23
7 files changed, 155 insertions, 0 deletions
diff --git a/debian/patches/0006-Include-cstdint-to-build-with-GCC-13.patch b/debian/patches/0006-Include-cstdint-to-build-with-GCC-13.patch
new file mode 100644
index 0000000..9743b11
--- /dev/null
+++ b/debian/patches/0006-Include-cstdint-to-build-with-GCC-13.patch
@@ -0,0 +1,21 @@
+From: Emanuele Rocca <ema@debian.org>
+Date: Thu, 24 Aug 2023 14:54:02 +0200
+Subject: Include cstdint to build with GCC-13
+
+[git-debrebase split: mixed commit: upstream part]
+---
+ src/os.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/os.h b/src/os.h
+index 7dd69b8..fd95af9 100644
+--- a/src/os.h
++++ b/src/os.h
+@@ -20,6 +20,7 @@
+ #include <unistd.h>
+ #include <sys/syscall.h>
+
++#include <cstdint>
+ #include <string>
+ #include <list>
+ #include <map>
diff --git a/debian/patches/allow-to-override-build-date-with-source.patch b/debian/patches/allow-to-override-build-date-with-source.patch
new file mode 100644
index 0000000..84edc28
--- /dev/null
+++ b/debian/patches/allow-to-override-build-date-with-source.patch
@@ -0,0 +1,36 @@
+From: "Bernhard M. Wiedemann" <bwiedemann@suse.de>
+Date: Sun, 9 Sep 2018 05:34:37 +0200
+Subject: Allow to override build date with SOURCE_DATE_EPOCH
+
+(Closes: #831587)
+
+in order to make builds reproducible.
+See https://reproducible-builds.org/ for why this is good
+and https://reproducible-builds.org/specs/source-date-epoch/
+for the definition of this variable.
+This date call works with all variants of date (GNU,BSD,Solaris).
+
+Also do not capture build user+host in this case
+to allow to get the same build results anywhere and anytime.
+---
+ configure.ac | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 9eed433..2681b5d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -96,6 +96,13 @@ timestamp=$(date)
+ AC_MSG_CHECKING([current timestamp])
+ AC_MSG_RESULT([$timestamp])
+
++if test -n "$SOURCE_DATE_EPOCH"
++then
++ timestamp=$(date -u -d "@$SOURCE_DATE_EPOCH" 2>/dev/null || date -u -r "$SOURCE_DATE_EPOCH" 2>/dev/null || date -u)
++ username=reproducible
++ hostname=reproducible
++fi
++
+ AC_DEFINE_UNQUOTED([STRESSAPPTEST_TIMESTAMP],
+ "$username @ $hostname on $timestamp",
+ [Timestamp when ./configure was executed])
diff --git a/debian/patches/armhf_support b/debian/patches/armhf_support
new file mode 100644
index 0000000..9652b48
--- /dev/null
+++ b/debian/patches/armhf_support
@@ -0,0 +1,24 @@
+From: Pierre Blanc <pierreblanc75@gmail.com>
+Date: Thu, 24 Aug 2023 14:42:39 +0200
+Subject: Fix armhf support patch to look for "arm" instead of "armv7l",
+
+Last-Update: 2012-12-02
+
+since configure is looking at the triplet, not uname output.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index ede7d26..fe8fd40 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -27,7 +27,7 @@ AS_CASE(["$host_cpu"],
+ AC_DEFINE([STRESSAPPTEST_CPU_PPC],[],
+ [Defined if the target CPU is PowerPC])
+ ],
+- [*armv7a*], [
++ [*arm*], [
+ AC_DEFINE([STRESSAPPTEST_CPU_ARMV7A],[],
+ [Defined if the target CPU is armv7a])
+ ],
diff --git a/debian/patches/fix-ftcbfs.-closes-986653.patch b/debian/patches/fix-ftcbfs.-closes-986653.patch
new file mode 100644
index 0000000..5d0b1a5
--- /dev/null
+++ b/debian/patches/fix-ftcbfs.-closes-986653.patch
@@ -0,0 +1,22 @@
+From: Helmut Grohne <helmut@subdivi.de>
+Date: Thu, 8 Apr 2021 20:38:30 +0200
+Subject: Fix FTCBFS. (Closes: #986653)
+
+---
+ configure.ac | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 2681b5d..f1ab99b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -129,6 +129,9 @@ AC_SEARCH_LIBS([io_setup], [aio])
+ AC_CHECK_HEADERS([sys/shm.h])
+ AC_SEARCH_LIBS([shm_open], [rt])
+
++AC_CHECK_TYPE([pthread_barrier_t],[
++ AC_DEFINE(HAVE_PTHREAD_BARRIER, [1], [Define to 1 if the system has `pthread_barrier'.])
++],[],[#include <pthread.h>])
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_HEADER_STDBOOL
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..75c25d4
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,6 @@
+armhf_support
+support_i486_builds
+support_i586_builds
+allow-to-override-build-date-with-source.patch
+fix-ftcbfs.-closes-986653.patch
+0006-Include-cstdint-to-build-with-GCC-13.patch
diff --git a/debian/patches/support_i486_builds b/debian/patches/support_i486_builds
new file mode 100644
index 0000000..ccd82b7
--- /dev/null
+++ b/debian/patches/support_i486_builds
@@ -0,0 +1,23 @@
+From: Michael Prokop <mika@debian.org>
+Date: Tue, 12 Jun 2012 01:01:39 +0200
+Subject: Support building on i486
+
+---
+ configure.ac | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index fe8fd40..459d8c6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -23,6 +23,10 @@ AS_CASE(["$host_cpu"],
+ AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
+ [Defined if the target CPU is i686])
+ ],
++ [*i486*], [
++ AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
++ [Defined if the target CPU is i486])
++ ],
+ [*powerpc*], [
+ AC_DEFINE([STRESSAPPTEST_CPU_PPC],[],
+ [Defined if the target CPU is PowerPC])
diff --git a/debian/patches/support_i586_builds b/debian/patches/support_i586_builds
new file mode 100644
index 0000000..588d557
--- /dev/null
+++ b/debian/patches/support_i586_builds
@@ -0,0 +1,23 @@
+From: Pierre Blanc <pierreblanc75@gmail.com>
+Date: Thu, 24 Aug 2023 14:42:39 +0200
+Subject: support_i586_builds
+
+---
+ configure.ac | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 459d8c6..9eed433 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -23,6 +23,10 @@ AS_CASE(["$host_cpu"],
+ AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
+ [Defined if the target CPU is i686])
+ ],
++ [*i586*], [
++ AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
++ [Defined if the target CPU is i586])
++ ],
+ [*i486*], [
+ AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
+ [Defined if the target CPU is i486])