summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac8
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/0003-configure.ac-Always-call-AC_CANONICAL_HOST.patch27
-rw-r--r--debian/patches/fix-ftcbfs.-closes-986653.patch4
-rw-r--r--debian/patches/series3
-rw-r--r--debian/patches/support_i486_builds23
-rw-r--r--debian/patches/support_i586_builds23
7 files changed, 31 insertions, 58 deletions
diff --git a/configure.ac b/configure.ac
index cde765e..2933d05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,14 +34,6 @@ AS_CASE(["$host_cpu"],
AC_DEFINE([STRESSAPPTEST_CPU_MIPS],[],
[Defined if the target CPU is MIPS])
],
- [*i586*], [
- AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
- [Defined if the target CPU is i586])
- ],
- [*i486*], [
- AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
- [Defined if the target CPU is i486])
- ],
[*powerpc*], [
AC_DEFINE([STRESSAPPTEST_CPU_PPC],[],
[Defined if the target CPU is PowerPC])
diff --git a/debian/changelog b/debian/changelog
index c937fda..168eb6c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
stressapptest (1.0.11-2) unstable; urgency=medium
* Fix the build on i386. Thanks Adrian Bunk.
+ * Drop i486 and i586 patches.
-- Emanuele Rocca <ema@debian.org> Sun, 08 Oct 2023 10:24:45 +0200
diff --git a/debian/patches/0003-configure.ac-Always-call-AC_CANONICAL_HOST.patch b/debian/patches/0003-configure.ac-Always-call-AC_CANONICAL_HOST.patch
new file mode 100644
index 0000000..e57e850
--- /dev/null
+++ b/debian/patches/0003-configure.ac-Always-call-AC_CANONICAL_HOST.patch
@@ -0,0 +1,27 @@
+From: Adrian Bunk <bunk@debian.org>
+Date: Sat, 7 Oct 2023 22:30:04 +0300
+Subject: configure.ac: Always call AC_CANONICAL_HOST
+
+This is required for host_os also with --with-cpu.
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8bd79fb..2933d05 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -13,10 +13,10 @@ fi
+
+ AC_ARG_WITH(cpu, [ --with-cpu define host cpu])
+
+-if test -z "$with_cpu"
++AC_CANONICAL_HOST
++
++if test -n "$with_cpu"
+ then
+- AC_CANONICAL_HOST
+-else
+ host_cpu=$with_cpu
+ fi
+ # Checking for target cpu and setting custom configuration
diff --git a/debian/patches/fix-ftcbfs.-closes-986653.patch b/debian/patches/fix-ftcbfs.-closes-986653.patch
index 5387ce0..5c42fd2 100644
--- a/debian/patches/fix-ftcbfs.-closes-986653.patch
+++ b/debian/patches/fix-ftcbfs.-closes-986653.patch
@@ -7,10 +7,10 @@ Subject: Fix FTCBFS. (Closes: #986653)
1 file changed, 3 insertions(+)
diff --git a/configure.ac b/configure.ac
-index 5c25486..3e8ac35 100644
+index 84665be..8bd79fb 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -146,6 +146,9 @@ AC_SEARCH_LIBS([io_setup], [aio])
+@@ -138,6 +138,9 @@ AC_SEARCH_LIBS([io_setup], [aio])
AC_CHECK_HEADERS([sys/shm.h])
AC_SEARCH_LIBS([shm_open], [rt])
diff --git a/debian/patches/series b/debian/patches/series
index e0d8a7c..592d327 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,3 @@
armhf_support
-support_i486_builds
-support_i586_builds
fix-ftcbfs.-closes-986653.patch
+0003-configure.ac-Always-call-AC_CANONICAL_HOST.patch
diff --git a/debian/patches/support_i486_builds b/debian/patches/support_i486_builds
deleted file mode 100644
index 94e0d7e..0000000
--- a/debian/patches/support_i486_builds
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Michael Prokop <mika@debian.org>
-Date: Tue, 12 Jun 2012 01:01:39 +0200
-Subject: Support building on i486
-
----
- configure.ac | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 84665be..d71b346 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -34,6 +34,10 @@ AS_CASE(["$host_cpu"],
- AC_DEFINE([STRESSAPPTEST_CPU_MIPS],[],
- [Defined if the target CPU is MIPS])
- ],
-+ [*i486*], [
-+ AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
-+ [Defined if the target CPU is i486])
-+ ],
- [*powerpc*], [
- AC_DEFINE([STRESSAPPTEST_CPU_PPC],[],
- [Defined if the target CPU is PowerPC])
diff --git a/debian/patches/support_i586_builds b/debian/patches/support_i586_builds
deleted file mode 100644
index dd19781..0000000
--- a/debian/patches/support_i586_builds
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Pierre Blanc <pierreblanc75@gmail.com>
-Date: Thu, 24 Aug 2023 14:42:39 +0200
-Subject: support_i586_builds
-
----
- configure.ac | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index d71b346..5c25486 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -34,6 +34,10 @@ AS_CASE(["$host_cpu"],
- AC_DEFINE([STRESSAPPTEST_CPU_MIPS],[],
- [Defined if the target CPU is MIPS])
- ],
-+ [*i586*], [
-+ AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
-+ [Defined if the target CPU is i586])
-+ ],
- [*i486*], [
- AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
- [Defined if the target CPU is i486])