summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2016-02-28 14:36:50 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2016-02-28 14:36:50 +0000
commit30cf732f4c0c46cfa778afdd4fcab97bc7c3401c (patch)
treefe3285940a6f3302100926f46f31f56fa8112c9a
parent3e8e22c03478e5ac5584eb35c4ca6bcf3989ffd1 (diff)
Build Python3 bindings. Closes: #815141
-rw-r--r--debian/changelog4
-rw-r--r--debian/compat2
-rw-r--r--debian/control38
-rw-r--r--debian/python-tdb.install2
-rw-r--r--debian/python3-tdb.install1
-rwxr-xr-xdebian/rules19
6 files changed, 55 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index f484549..2b09437 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,11 @@
tdb (1.3.8-2) UNRELEASED; urgency=medium
+ [ Jelmer Vernooij ]
* Drop '-b unstable' flag to Vcs-Git.
+ [ Matthias Klose ]
+ * Build Python3 bindings. Closes: #815141
+
-- Jelmer Vernooij <jelmer@debian.org> Sun, 13 Dec 2015 16:10:29 +0000
tdb (1.3.8-1) unstable; urgency=medium
diff --git a/debian/compat b/debian/compat
index 45a4fb7..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-8
+9
diff --git a/debian/control b/debian/control
index adb46d9..2d54990 100644
--- a/debian/control
+++ b/debian/control
@@ -3,12 +3,12 @@ Section: devel
Priority: optional
Maintainer: Debian Samba Maintainers <pkg-samba-maint@lists.alioth.debian.org>
Uploaders: Jelmer Vernooij <jelmer@debian.org>
-Build-Depends: debhelper (>= 8.1.3),
+Build-Depends: debhelper (>= 9),
dh-python,
docbook-xml,
docbook-xsl,
- python-all-dbg (>= 2.6.6-3),
- python-all-dev (>= 2.6.6-3),
+ python-dev (>= 2.6.6-3),
+ python3-dev,
xsltproc
Homepage: http://tdb.samba.org/
Standards-Version: 3.9.6
@@ -98,3 +98,35 @@ Description: Python bindings for TDB - debug extension
appropriate locking and transactions.
.
This package contains the Python debug extension.
+
+Package: python3-tdb
+Section: python
+Architecture: linux-any kfreebsd-any
+Depends: libtdb1 (= ${binary:Version}),
+ ${misc:Depends},
+ ${python3:Depends},
+ ${shlibs:Depends}
+Provides: ${python3:Provides}
+Description: Python3 bindings for TDB
+ This is a simple database API. It is modelled after the structure
+ of GDBM. TDB features, unlike GDBM, multiple writers support with
+ appropriate locking and transactions.
+ .
+ This package contains the Python3 bindings.
+
+Package: python3-tdb-dbg
+Section: debug
+Architecture: linux-any kfreebsd-any
+Priority: extra
+Depends: python3-tdb (= ${binary:Version}),
+ ${misc:Depends},
+ ${python3:Depends},
+ ${shlibs:Depends}
+Recommends: python3-dbg, libtdb1-dbg
+Provides: ${python3:Provides}
+Description: Python3 bindings for TDB - debug extension
+ This is a simple database API. It is modelled after the structure
+ of GDBM. TDB features, unlike GDBM, multiple writers support with
+ appropriate locking and transactions.
+ .
+ This package contains the Python3 debug extension.
diff --git a/debian/python-tdb.install b/debian/python-tdb.install
index 607c065..b2cc136 100644
--- a/debian/python-tdb.install
+++ b/debian/python-tdb.install
@@ -1 +1 @@
-usr/lib/python*
+usr/lib/python2*
diff --git a/debian/python3-tdb.install b/debian/python3-tdb.install
new file mode 100644
index 0000000..4606faa
--- /dev/null
+++ b/debian/python3-tdb.install
@@ -0,0 +1 @@
+usr/lib/python3*
diff --git a/debian/rules b/debian/rules
index 05147f1..2393aa0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,16 +10,19 @@ LDFLAGS += -Wl,--as-needed
DESTDIR=$(CURDIR)/debian/tmp
export PYTHON=$(shell which `pyversions -d`)
-export PYTHON_CONFIG=$(PYTHON)-config
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
%:
- dh $* --with python2
+ dh $* --with python2,python3
override_dh_auto_configure:
- CPPFLAGS="$(CPPFLAGS)" PYTHON="$(PYTHON)" PYTHON_CONFIG="$(PYTHON_CONFIG)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
- ./configure --prefix=/usr --disable-rpath-install --libdir=/usr/lib/$(DEB_HOST_MULTIARCH)
+ PYTHON="$(PYTHON)" \
+ CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
+ ./configure --prefix=/usr --disable-rpath-install \
+ --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ --extra-python=python3 \
+ -v
get-packaged-orig-source:
./debian/build-orig.sh
@@ -28,7 +31,7 @@ override_dh_python2:
dh_python2 --no-guessing-versions
override_dh_auto_build:
- $(MAKE) all
+ $(MAKE) all V=2
override_dh_auto_test:
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
@@ -47,6 +50,9 @@ override_dh_auto_clean:
third_party/waf/wafadmin/*.pyc \
third_party/waf/wafadmin/Tools/*.pyc
+override_dh_install:
+ dh_install --list-missing
+
override_dh_auto_install:
$(MAKE) install DESTDIR=$(DESTDIR)
# Waf should be doing this..
@@ -60,7 +66,8 @@ override_dh_auto_install:
override_dh_strip:
dh_strip -p libtdb1 --dbg-package=libtdb1-dbg
dh_strip -p python-tdb --dbg-package=python-tdb-dbg
+ dh_strip -p python3-tdb --dbg-package=python3-tdb-dbg
dh_strip -p tdb-tools
override_dh_makeshlibs:
- dh_makeshlibs -- -c4
+ dh_makeshlibs -Npython-tdb -Npython3-tdb -- -c4