summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSophie Brun <sophie@freexian.com>2018-03-06 14:16:23 +0100
committerSophie Brun <sophie@freexian.com>2018-03-06 14:16:23 +0100
commit81e459838c92199fbe27bd648575d973f1c5699e (patch)
tree86166cbca0b469a4f1b7e1db00b978a4003dccc3
parent192624dc04a10891b300a9fa517a24581da2654e (diff)
Create a separated package for documentation
-rw-r--r--debian/control29
-rw-r--r--debian/docs1
-rw-r--r--debian/examples16
-rw-r--r--debian/python-urwid-doc.docs1
-rw-r--r--debian/python-urwid-doc.examples1
-rwxr-xr-xdebian/rules4
6 files changed, 31 insertions, 21 deletions
diff --git a/debian/control b/debian/control
index 1b41af1..9ea5d45 100644
--- a/debian/control
+++ b/debian/control
@@ -7,10 +7,10 @@ Build-Depends:
debhelper (>= 9),
python-all-dev (>= 2.6.6-3~),
python-setuptools (>= 0.6.16),
- python-sphinx,
python-twisted,
python3-all-dev (>= 3.2),
- python3-setuptools
+ python3-setuptools,
+ python3-sphinx
Standards-Version: 3.9.6
Homepage: http://urwid.org/
Vcs-Git: https://salsa.debian.org/python-team/modules/urwid.git
@@ -23,6 +23,7 @@ Package: python-urwid
Architecture: any
Depends: ${misc:Depends}, ${python:Depends}, ${shlibs:Depends}
Provides: ${python:Provides}
+Suggests: python-urwid-doc
Description: curses-based UI/widget library for Python 2
Urwid is a console user interface library that includes many features
useful for text console application developers including:
@@ -46,6 +47,7 @@ Package: python3-urwid
Architecture: any
Depends: ${misc:Depends}, ${python3:Depends}, ${shlibs:Depends}
Provides: ${python:Provides}
+Suggests: python-urwid-doc
Description: curses-based UI/widget library for Python 3
Urwid is a console user interface library that includes many features
useful for text console application developers including:
@@ -64,3 +66,26 @@ Description: curses-based UI/widget library for Python 3
* Easy interface for creating HTML screen shots
.
This is the Python 3 version of the package.
+
+Package: python-urwid-doc
+Architecture: all
+Section: doc
+Depends: ${misc:Depends}, ${sphinxdoc:Depends}
+Description: curses-based UI/widget library (common documentation)
+ Urwid is a console user interface library that includes many features
+ useful for text console application developers including:
+ .
+ * Fluid interface resizing (xterm window resizing/fbset on Linux console)
+ * Web application display mode using Apache and CGI
+ * Support for UTF-8, simple 8-bit and CJK encodings
+ * Multiple text alignment and wrapping modes built-in
+ * Ability to create user-defined text layout classes
+ * Simple markup for setting text attributes
+ * Powerful list box that handles scrolling between different widget types
+ * List box contents may be managed with a user-defined class
+ * Flexible edit box for editing many different types of text
+ * Buttons, check boxes and radio boxes
+ * Customizable layout for all widgets
+ * Easy interface for creating HTML screen shots
+ .
+ This is the common documentation package.
diff --git a/debian/docs b/debian/docs
deleted file mode 100644
index 6f7511e..0000000
--- a/debian/docs
+++ /dev/null
@@ -1 +0,0 @@
-build/sphinx/html
diff --git a/debian/examples b/debian/examples
deleted file mode 100644
index 8039f08..0000000
--- a/debian/examples
+++ /dev/null
@@ -1,16 +0,0 @@
-examples/browse.py
-examples/calc.py
-examples/dialog.py
-examples/edit.py
-examples/fib.py
-examples/input_test.py
-examples/tour.py
-examples/graph.py
-examples/bigtext.py
-examples/palette_test.py
-examples/treesample.py
-examples/subproc.py
-examples/pop_up.py
-examples/twisted_serve_ssh.py
-examples/twisted_serve_ssh.tac
-examples/lcd_cf635.py
diff --git a/debian/python-urwid-doc.docs b/debian/python-urwid-doc.docs
new file mode 100644
index 0000000..6d28621
--- /dev/null
+++ b/debian/python-urwid-doc.docs
@@ -0,0 +1 @@
+build/html
diff --git a/debian/python-urwid-doc.examples b/debian/python-urwid-doc.examples
new file mode 100644
index 0000000..e39721e
--- /dev/null
+++ b/debian/python-urwid-doc.examples
@@ -0,0 +1 @@
+examples/*
diff --git a/debian/rules b/debian/rules
index 9160417..53f803f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,12 +3,12 @@
export PYBUILD_NAME=urwid
%:
- dh $@ --with python2,python3 --buildsystem=pybuild
+ dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_clean:
rm -f urwid/tests/test_vterm.py
dh_auto_clean
override_dh_auto_build:
- python setup.py build_sphinx
dh_auto_build
+ PYTHONPATH=. http_proxy='127.0.0.1:9' sphinx-build -N -bhtml docs build/html # HTML generator