summaryrefslogtreecommitdiff
path: root/yphelper/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'yphelper/Makefile.am')
-rw-r--r--yphelper/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/yphelper/Makefile.am b/yphelper/Makefile.am
new file mode 100644
index 0000000..9c34cbe
--- /dev/null
+++ b/yphelper/Makefile.am
@@ -0,0 +1,32 @@
+#
+# Copyright (c) 2001, 2002, 2003, 2007, 2009 Thorsten Kukuk <kukuk@linux-nis.org>
+#
+AUTOMAKE_OPTIONS = 1.7 gnits
+
+localedir = $(datadir)/locale
+
+AM_CPPFLAGS = -I$(top_srcdir)/lib -I$(top_srcdir) -I$(top_builddir) -I$(srcdir)
+
+DEFS = @DEFS@ -DLOCALEDIR=\"$(localedir)\" -DYPBINDIR=\"$(libexecdir)\" \
+ -DCONFDIR=\"$(sysconfdir)\" -DYPMAPDIR=\"@YPMAPDIR@\" \
+ -DUSE_FQDN=@USE_FQDN@
+
+CLEANFILES = *~
+
+EXTRA_DIST = ${MANS} ${XMLS}
+
+XMLS = yphelper.8.xml
+man_MANS = yphelper.8
+
+libexec_PROGRAMS = yphelper
+
+yphelper_SOURCES = yphelper.c
+
+yphelper_LDADD = $(top_builddir)/lib/libyp.a @LIBDBM@ @NSL_LIBS@ @TIRPC_LIBS@
+yphelper_CFLAGS = @NSL_CFLAGS@ @TIRPC_CFLAGS@
+
+if ENABLE_REGENERATE_MAN
+%.8: %.8.xml
+ $(XMLLINT) --nonet --xinclude --postvalid --noout $<
+ $(XSLTPROC) -o $(srcdir)/$@ --path $(srcdir) --xinclude --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+endif