summaryrefslogtreecommitdiff
path: root/debian/patches/etcmakefile.-pass-arguments-to-date-to-s.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/etcmakefile.-pass-arguments-to-date-to-s.patch')
-rw-r--r--debian/patches/etcmakefile.-pass-arguments-to-date-to-s.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/patches/etcmakefile.-pass-arguments-to-date-to-s.patch b/debian/patches/etcmakefile.-pass-arguments-to-date-to-s.patch
new file mode 100644
index 0000000..a9dfe87
--- /dev/null
+++ b/debian/patches/etcmakefile.-pass-arguments-to-date-to-s.patch
@@ -0,0 +1,34 @@
+From: Vagrant Cascadian <vagrant@reproducible-builds.org>
+Date: Tue, 29 Dec 2020 07:16:56 +0000
+Subject: etc/Makefile.*: Pass arguments to date to support SOURCE_DATE_EPOCH
+ when generating README. (Closes: #978610)
+
+---
+ etc/Makefile.am | 2 +-
+ etc/Makefile.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/etc/Makefile.am b/etc/Makefile.am
+index fa53029..400b9ca 100644
+--- a/etc/Makefile.am
++++ b/etc/Makefile.am
+@@ -59,5 +59,5 @@ a2ps.cfg: a2ps_cfg Makefile
+
+ # Building a timestamp to know the version.
+ README: README.in Makefile
+- sed "s!@date@!`date`!g;s!@version@!$(VERSION)!g" \
++ sed "s!@date@!`LC_ALL=C date --utc --date=@$(SOURCE_DATE_EPOCH)`!g;s!@version@!$(VERSION)!g" \
+ $(srcdir)/README.in > README
+diff --git a/etc/Makefile.in b/etc/Makefile.in
+index 9264bf7..c4a45cc 100644
+--- a/etc/Makefile.in
++++ b/etc/Makefile.in
+@@ -1663,7 +1663,7 @@ a2ps.cfg: a2ps_cfg Makefile
+
+ # Building a timestamp to know the version.
+ README: README.in Makefile
+- sed "s!@date@!`date`!g;s!@version@!$(VERSION)!g" \
++ sed "s!@date@!`LC_ALL=C date --utc --date=@$(SOURCE_DATE_EPOCH)`!g;s!@version@!$(VERSION)!g" \
+ $(srcdir)/README.in > README
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.