summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDebian Multimedia Maintainers <debian-multimedia@lists.debian.org>2023-01-11 11:13:10 +0100
committerIOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>2023-01-11 11:13:10 +0100
commit910563ecfcee7c2d3aa108a680e9031e6c9bad92 (patch)
treed8bfceff52223e644f269dfafe0c50574f13e049
parenta7eb7e884879336f1e51ef2ccab62f4abb64d1da (diff)
Allow disabling the building of tests
Origin: Debian Bug: https://github.com/Ableton/link/issues/128 Last-Update: 2023-01-10 E.g. when using the 'nocheck' profile Last-Update: 2023-01-10 Gbp-Pq: Name nocheck.patch
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5924722..b2d55d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,8 @@ if(WIN32)
option(LINK_BUILD_VLD "Build with VLD support (VLD must be installed separately)" OFF)
endif()
+option(LINK_BUILD_TESTS "Build unit test binaries" ON)
+
# ____ _ _
# | _ \ __ _| |_| |__ ___
# | |_) / _` | __| '_ \/ __|
@@ -36,7 +38,9 @@ include(AbletonLinkConfig.cmake)
include(extensions/abl_link/abl_link.cmake)
add_subdirectory(include)
+if(LINK_BUILD_TESTS)
add_subdirectory(src)
+endif()
add_subdirectory(examples)
add_subdirectory(extensions/abl_link)