summaryrefslogtreecommitdiff
path: root/books/workshops/2015/chau-kaufmann-hunt/support/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'books/workshops/2015/chau-kaufmann-hunt/support/Makefile')
-rw-r--r--books/workshops/2015/chau-kaufmann-hunt/support/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/books/workshops/2015/chau-kaufmann-hunt/support/Makefile b/books/workshops/2015/chau-kaufmann-hunt/support/Makefile
new file mode 100644
index 0000000..6793a53
--- /dev/null
+++ b/books/workshops/2015/chau-kaufmann-hunt/support/Makefile
@@ -0,0 +1,30 @@
+# Cuong Chau
+
+# Usage:
+
+# make JOBS=2 \
+# ACL2r=<Path of the ACL2r image>
+
+# To remove certificate files, etc., execute the following:
+#
+# make clean ACL2r=<Path of the ACL2r image>
+
+#======================================================================
+.PHONY: all clean
+#======================================================================
+
+ifndef ACL2r
+ $(error Variable ACL2r is undefined.)
+endif
+
+BUILD_DIR := $(dir $(ACL2r))books/build
+JOBS ?= 2
+
+#======================================================================
+
+all:
+ $(BUILD_DIR)/cert.pl -j $(JOBS) -a $(ACL2r) fourier-sums int-infinite-sum-1 int-infinite-sum-2
+
+clean:
+ $(BUILD_DIR)/clean.pl
+