summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2019-07-15 14:47:44 +0200
committerStephane Glondu <steph@glondu.net>2019-07-15 14:51:43 +0200
commita6436c6e3460e61afbc92c1c41a3596fe6743ef9 (patch)
treef01732cf15faa21231a89510b4818f8e413a4e2e
parent69a402c559e513fc92614f6d921cd911a9a101eb (diff)
Patch upstream Makefile to not overwrite dpkg-buildflags CFLAGS (Closes: #763180)
-rw-r--r--debian/patches/01_dont_overwrite_cflags.diff23
-rw-r--r--debian/patches/series1
2 files changed, 24 insertions, 0 deletions
diff --git a/debian/patches/01_dont_overwrite_cflags.diff b/debian/patches/01_dont_overwrite_cflags.diff
new file mode 100644
index 0000000..2626c6a
--- /dev/null
+++ b/debian/patches/01_dont_overwrite_cflags.diff
@@ -0,0 +1,23 @@
+From: Guillaume Delacour <gui@iroqwa.org>
+Date: Mon, 15 Jul 2019 14:49:56 +0200
+Subject: Don't overwrite dpkg-buildflags CFLAGS
+
+Bug-Debian: https://bugs.debian.org/763180
+Last-Update: 2014-09-28
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index e52eeb7..2ecb3b5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@ CDEBUGFLAGS = -Os -g -Wall
+
+ DEFINES = $(PLATFORM_DEFINES)
+
+-CFLAGS = $(CDEBUGFLAGS) $(DEFINES) $(EXTRA_DEFINES)
++CFLAGS += $(CDEBUGFLAGS) $(DEFINES) $(EXTRA_DEFINES)
+
+ SRCS = ahcpd.c monotonic.c transport.c prefix.c configure.c config.c lease.c
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..edc385b
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+01_dont_overwrite_cflags.diff