summaryrefslogtreecommitdiff
path: root/aom_dsp/psnrhvs.c
diff options
context:
space:
mode:
authorYaowu Xu <yaowu@google.com>2016-08-30 14:01:10 -0700
committerYaowu Xu <yaowu@google.com>2016-08-31 18:19:03 -0700
commitf883b42cabd100e575becdfb8f361f953942fe02 (patch)
tree612f6c31e257ec26cd6e6ce32055a9182c91ad9a /aom_dsp/psnrhvs.c
parentc27fc14b02dd41f677290022b0de2d296f5e6dca (diff)
Port renaming changes from AOMedia
Cherry-Picked the following commits: 0defd8f Changed "WebM" to "AOMedia" & "webm" to "aomedia" 54e6676 Replace "VPx" by "AVx" 5082a36 Change "Vpx" to "Avx" 7df44f1 Replace "Vp9" w/ "Av1" 967f722 Remove kVp9CodecId 828f30c Change "Vp8" to "AOM" 030b5ff AUTHORS regenerated 2524cae Add ref-mv experimental flag 016762b Change copyright notice to AOMedia form 81e5526 Replace vp9 w/ av1 9b94565 Add missing files fa8ca9f Change "vp9" to "av1" ec838b7 Convert "vp8" to "aom" 80edfa0 Change "VP9" to "AV1" d1a11fb Change "vp8" to "aom" 7b58251 Point to WebM test data dd1a5c8 Replace "VP8" with "AOM" ff00fc0 Change "VPX" to "AOM" 01dee0b Change "vp10" to "av1" in source code cebe6f0 Convert "vpx" to "aom" 17b0567 rename vp10*.mk to av1_*.mk fe5f8a8 rename files vp10_* to av1_* Change-Id: I6fc3d18eb11fc171e46140c836ad5339cf6c9419
Diffstat (limited to 'aom_dsp/psnrhvs.c')
-rw-r--r--aom_dsp/psnrhvs.c16
1 files changed, 8 insertions, 8 deletions
diff --git a/aom_dsp/psnrhvs.c b/aom_dsp/psnrhvs.c
index 333ff6352..f7b78ae7a 100644
--- a/aom_dsp/psnrhvs.c
+++ b/aom_dsp/psnrhvs.c
@@ -15,8 +15,8 @@
#include <stdlib.h>
#include <math.h>
-#include "./vpx_config.h"
-#include "./vpx_dsp_rtcd.h"
+#include "./aom_config.h"
+#include "./aom_dsp_rtcd.h"
#include "aom_dsp/ssim.h"
#include "aom_ports/system_state.h"
#include "aom_dsp/psnr.h"
@@ -30,17 +30,17 @@ static void od_bin_fdct8x8(tran_low_t *y, int ystride, const int16_t *x,
int xstride) {
int i, j;
(void)xstride;
- vpx_fdct8x8(x, y, ystride);
+ aom_fdct8x8(x, y, ystride);
for (i = 0; i < 8; i++)
for (j = 0; j < 8; j++)
*(y + ystride * i + j) = (*(y + ystride * i + j) + 4) >> 3;
}
-#if CONFIG_VP9_HIGHBITDEPTH
+#if CONFIG_AOM_HIGHBITDEPTH
static void hbd_od_bin_fdct8x8(tran_low_t *y, int ystride, const int16_t *x,
int xstride) {
int i, j;
(void)xstride;
- vpx_highbd_fdct8x8(x, y, ystride);
+ aom_highbd_fdct8x8(x, y, ystride);
for (i = 0; i < 8; i++)
for (j = 0; j < 8; j++)
*(y + ystride * i + j) = (*(y + ystride * i + j) + 4) >> 3;
@@ -210,7 +210,7 @@ static double calc_psnrhvs(const unsigned char *src, int _systride,
s_gvar = (s_vars[0] + s_vars[1] + s_vars[2] + s_vars[3]) / s_gvar;
if (d_gvar > 0)
d_gvar = (d_vars[0] + d_vars[1] + d_vars[2] + d_vars[3]) / d_gvar;
-#if CONFIG_VP9_HIGHBITDEPTH
+#if CONFIG_AOM_HIGHBITDEPTH
if (bit_depth == 10 || bit_depth == 12) {
hbd_od_bin_fdct8x8(dct_s_coef, 8, dct_s, 8);
hbd_od_bin_fdct8x8(dct_d_coef, 8, dct_d, 8);
@@ -246,7 +246,7 @@ static double calc_psnrhvs(const unsigned char *src, int _systride,
return ret;
}
-double vpx_psnrhvs(const YV12_BUFFER_CONFIG *src,
+double aom_psnrhvs(const YV12_BUFFER_CONFIG *src,
const YV12_BUFFER_CONFIG *dest, double *y_psnrhvs,
double *u_psnrhvs, double *v_psnrhvs, uint32_t bd,
uint32_t in_bd) {
@@ -254,7 +254,7 @@ double vpx_psnrhvs(const YV12_BUFFER_CONFIG *src,
const double par = 1.0;
const int step = 7;
uint32_t bd_shift = 0;
- vpx_clear_system_state();
+ aom_clear_system_state();
assert(bd == 8 || bd == 10 || bd == 12);
assert(bd >= in_bd);