summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorCotton Seed <cotton@alum.mit.edU>2015-10-25 13:46:11 -0400
committerCotton Seed <cotton@alum.mit.edU>2015-10-25 13:46:11 -0400
commit84958ed6082243c64cbefb639210ce67a37918b9 (patch)
tree7cd9c967f5da2f228a8c33e77a2e52a0945e4af1 /Makefile
parent8ebc0774de386a0d2c9f6b2143b1f5ab61011b8d (diff)
Added fuzz-pcf target to run afl on pcf input.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4f82bb7..453cfa7 100644
--- a/Makefile
+++ b/Makefile
@@ -73,6 +73,9 @@ testvg:
@echo 'All tests passed.'
@echo
+fuzz-pcf: all
+ afl-fuzz -t 2500 -m 500 -i fuzz/pcf/testcases -o fuzz/pcf/findings bin/arachne-pnr -p @@ fuzz/pcf/rot.blif
+
-include src/*.d
.PHONY: install