summaryrefslogtreecommitdiff
path: root/doc/python_module.rst
diff options
context:
space:
mode:
Diffstat (limited to 'doc/python_module.rst')
-rw-r--r--doc/python_module.rst33
1 files changed, 33 insertions, 0 deletions
diff --git a/doc/python_module.rst b/doc/python_module.rst
new file mode 100644
index 0000000..eab5cd4
--- /dev/null
+++ b/doc/python_module.rst
@@ -0,0 +1,33 @@
+aubio Python module
+===================
+
+Building the module
+-------------------
+
+From ``aubio`` source directory, run the following:
+
+.. code-block:: bash
+
+ $ cd python
+ $ ./setup.py build
+ $ sudo ./setup.py install
+
+Using the module
+----------------
+
+To use the python module, simply import aubio:
+
+.. code-block:: python
+
+ #! /usr/bin/env python
+ import aubio
+
+ s = aubio.source(sys.argv[1], 0, 256)
+ while True:
+ samples, read = s()
+ print samples
+ if read < 256: break
+
+Check out the `python demos for aubio
+<https://github.com/piem/aubio/blob/develop/python/demos/>`_ for more examples.
+