summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorØyvind Kolås <ok@src.gnome.org>2006-11-15 19:33:52 +0000
committerØyvind Kolås <ok@src.gnome.org>2006-11-15 19:33:52 +0000
commite6b492fa35ade979eb2f95506902de54a89d68f4 (patch)
tree93eb229c9f5fe2af6c157e1a7b39d7bceedf14fe
parentfc5bbc3d98ec01e7ab42520b124d5b10de01ae79 (diff)
Set the default BABL_PATH based on the prefix babl is compiled for.
* babl/Makefile.am: * babl/babl-extension.c:
-rw-r--r--ChangeLog7
-rw-r--r--babl/Makefile.am2
-rw-r--r--babl/babl-extension.c2
3 files changed, 10 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 30f1f05..305f633 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+2006-11-15 Øyvind Kolås <pippin@gimp.org>
+
+ Set the default BABL_PATH based on the prefix babl is compiled for.
+
+ * babl/Makefile.am:
+ * babl/babl-extension.c:
+
2006-11-07 Øyvind Kolås <pippin@gimp.org>
* extensions/CIE-Lab.c: (formats): added "CIE Lab alpha float" as
diff --git a/babl/Makefile.am b/babl/Makefile.am
index ffc0338..81b28f9 100644
--- a/babl/Makefile.am
+++ b/babl/Makefile.am
@@ -46,6 +46,8 @@ library_include_HEADERS = \
INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/babl/base
+AM_CPPFLAGS = -DPREFIX=\""$(prefix)"\"
+
lib_LTLIBRARIES= libbabl.la
libbabl_la_SOURCES= $(h_sources) $(c_sources)
libbabl_la_LIBADD=\
diff --git a/babl/babl-extension.c b/babl/babl-extension.c
index 2352586..812e405 100644
--- a/babl/babl-extension.c
+++ b/babl/babl-extension.c
@@ -22,7 +22,7 @@
#ifdef HAVE_CONFIG_H
#include "config.h"
#else
-#define BABL_PATH "~/.babl-0.0:/usr/local/lib/babl-0.0:/usr/lib/babl-0.0";
+#define BABL_PATH PREFIX "/babl-0.0"
#define BABL_PATH_SEPERATOR "/"
#define BABL_LIST_SEPERATOR ':'
#endif