summaryrefslogtreecommitdiff
path: root/babl/base
diff options
context:
space:
mode:
authorØyvind Kolås <pippin@gimp.org>2019-11-08 19:07:47 +0100
committerØyvind Kolås <pippin@gimp.org>2019-11-08 19:07:50 +0100
commit84128d538aa4f189c31d296d04084762ce062107 (patch)
tree6a51b4508890b43948b0d667013511f68276b1e6 /babl/base
parente41da81b67128a8d29d8fd106e5b1ac53da16ecb (diff)
build: opt out of unsafe math optimizations in reference and base
This makes the reference code paths used for verifying conversions in extensions not involve for instance fast reciprocal approximations, see issue #49. The extensions are still compiled with full optimizations.
Diffstat (limited to 'babl/base')
-rw-r--r--babl/base/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/babl/base/meson.build b/babl/base/meson.build
index 97ec38b..06728de 100644
--- a/babl/base/meson.build
+++ b/babl/base/meson.build
@@ -16,6 +16,12 @@ babl_base_sources = [
'type-u8.c',
]
+babl_base_c_args = [
+ sse2_cflags,
+ '-DLIBDIR="@0@"'.format(babl_libdir),
+ '-fno-unsafe-math-optimizations'
+]
+
babl_base = static_library('babl_base',
babl_base_sources,
include_directories: [ rootInclude, bablInclude, ],