summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorJeremy Bicha <jbicha@debian.org>2019-10-27 12:54:09 -0400
committerJeremy Bicha <jbicha@debian.org>2019-10-27 12:55:34 -0400
commitdaf0faa6febbb9cb0d189a01c54491322ffe40ff (patch)
treeceed9562719a4fbc18305a1f0ed47a0eade9ac85 /debian/patches
parent44fcbe28885651099c39c84847038fbd25078e7b (diff)
Add tests-increase-timeout.patch:
- Increase meson timeout limit so that the armel build succeeds Gbp-Dch: Full
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/tests-increase-timeout.patch24
2 files changed, 25 insertions, 0 deletions
diff --git a/debian/patches/series b/debian/patches/series
index e69de29..b805e74 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -0,0 +1 @@
+tests-increase-timeout.patch
diff --git a/debian/patches/tests-increase-timeout.patch b/debian/patches/tests-increase-timeout.patch
new file mode 100644
index 0000000..fa29ce1
--- /dev/null
+++ b/debian/patches/tests-increase-timeout.patch
@@ -0,0 +1,24 @@
+From: Jeremy Bicha <jbicha@debian.org>
+Date: Sun, 27 Oct 2019 12:53:09 -0400
+Subject: tests: increase timeout to 120 seconds
+
+meson's default test timeout is 30 seconds which is a bit too slow
+for Debian's armel build machine.
+
+https://mesonbuild.com/Reference-manual.html#test
+https://buildd.debian.org/status/logs.php?pkg=babl&arch=armel
+---
+ tests/meson.build | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index dfe7d45..c03e1a4 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -50,5 +50,6 @@ foreach test_name : test_names
+ test,
+ env: test_env,
+ workdir: meson.current_build_dir(),
++ timeout: 120,
+ )
+ endforeach