summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorFélix Piédallu <felix@piedallu.me>2017-12-01 15:57:41 +0100
committerØyvind Kolås <pippin@gimp.org>2017-12-16 02:44:00 +0100
commitdaeeb261a58372a544e38af2aed5af35c3624369 (patch)
treec56ac1f825d5d3b43ba191f19ee67b72907d089d /docs
parentc3b6d999a90fde28e09fe7d43f7feb0f269bfa86 (diff)
Use formatting instead of weird path reconstruction
Diffstat (limited to 'docs')
-rw-r--r--docs/meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/docs/meson.build b/docs/meson.build
index 04ba667..3a5115b 100644
--- a/docs/meson.build
+++ b/docs/meson.build
@@ -19,8 +19,7 @@ index_html_tmp = custom_target('index.html.tmp',
input : [ babl_html_dump, ],
output: [ 'index.html.tmp', ],
command: [ 'bash', '-c',
- 'BABL_PATH="' + join_paths(meson.build_root(), 'extensions') +'"'
- + ' ' + babl_html_dump.full_path()
+ 'BABL_PATH="'+ join_paths(meson.build_root(), 'extensions') +'" '+ babl_html_dump.full_path()
],
capture: true,
)
@@ -35,7 +34,7 @@ index_html = custom_target('index.html',
],
output: [ 'index.html', ],
command: [ 'bash', '-c',
- 'cp '+ join_paths(meson.build_root(), meson.current_source_dir(), 'index-static.html') +' @OUTPUT@'
+ 'cp '+ '@0@'.format(index_static_html) +' @OUTPUT@'
+' && '+ xml_insert.path() +' @OUTPUT@ BablBase '+ index_html_tmp.full_path()
+' && '+ xml_insert.path() +' @OUTPUT@ AUTHORS '+ join_paths(meson.source_root(), 'AUTHORS')
+' && '+ xml_insert.path() +' @OUTPUT@ TODO '+ join_paths(meson.source_root(), 'TODO')