summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2016-07-22 21:17:45 +0200
committerAlfred E. Heggestad <aeh@db.org>2016-07-22 21:17:45 +0200
commit3625c3196fe1ba7f3695d30379316c2e250ee54b (patch)
tree7558717b6dfefa8eb9efbb1a3995c7b4611099e7
parent693c8abde6489adfd75a62ab3b2578f581b21f0b (diff)
baresip version 0.4.20
-rw-r--r--Makefile2
-rw-r--r--debian/changelog6
-rw-r--r--docs/ChangeLog69
-rw-r--r--include/baresip.h2
-rw-r--r--mk/Doxyfile2
-rw-r--r--rpm/baresip.spec2
6 files changed, 79 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 9d2b847..6d73456 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@
USE_VIDEO := 1
PROJECT := baresip
-VERSION := 0.4.19
+VERSION := 0.4.20
DESCR := "Baresip is a modular SIP User-Agent with audio and video support"
# Verbose and silent build modes
diff --git a/debian/changelog b/debian/changelog
index 4a87c69..0b2e55a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+baresip (0.4.20) unstable; urgency=medium
+
+ * version 0.4.20
+
+ -- Alfred E. Heggestad <aeh@db.org> Fri, 22 July 2016 20:00:00 +0100
+
baresip (0.4.19) unstable; urgency=medium
* version 0.4.19
diff --git a/docs/ChangeLog b/docs/ChangeLog
index a1fcaf2..b5b98a4 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,72 @@
+2016-07-22 Alfred E. Heggestad <aeh@db.org>
+
+ * Version 0.4.20
+
+ * GIT URL: https://github.com/alfredh/baresip.git
+ * GIT tag: v0.4.20
+ * NOTE: Requires libre v0.4.17 or later
+ Requires librem v0.4.7 or later
+
+ * new modules:
+ - pulse Pulseaudio driver
+ - vp9 VP9 video codec
+
+ * config:
+ - audio_path Path to audio files
+ - call_local_timeout Timeout for incoming calls
+ - redial_attempts Number of redial attempts
+ - redial_delay Redial delay in seconds
+
+ * baresip-core:
+ - baresip: added a global baresip instance (WIP)
+ - call: add RTP timeout (thanks to Sveriges Radio)
+ - config: added call_local_timeout for incoming call timeout
+ - config: added compile-time configureable CONFIG_PATH
+ - config: added 'audio_path' config variable (thanks Juha Heinanen)
+ - net: made it re-entrant with struct network
+ - ua: added uag_set_exit_handler
+ - ua: fix bug with reg_uri limited to 64-chars
+ - video: vidfilters should not modify decoded image
+
+ * selftest:
+ - add test for network
+ - add test for sending SIP OPTIONS
+ - add test for RTP timeout
+
+ * Modules:
+
+ * avcodec: fix usage of deprecated API
+
+ * avformat: remove support for scaling
+ fix usage of deprecated API
+
+ * cons: relay log-messages to active UDP/TCP connections
+ https://github.com/alfredh/baresip/issues/144
+
+ * h265: fix usage of deprecated API
+
+ * menu: added support for re-dial on failure
+ (thanks to Sveriges Radio)
+
+ * mpa: Bug with reinit of codec structs (thanks Christian Hoene)
+
+ * natpmp: added support for RTCP
+
+ * presence: use correct struct in deref handler
+
+ * pulse: new module for Pulseaudio driver
+ (thanks to Matthias Apitz for testing)
+
+ * vidloop: vidfilters should not modify decoded image
+
+ * vp8: module renamed from vpx.so to vp8.so
+
+ * vp9: new module implementing VP9 video codec
+
+ * wincons: use ReadConsoleInput, thanks to GGGO (fixes #139)
+ https://github.com/alfredh/baresip/issues/139
+
+
2016-05-20 Alfred E. Heggestad <aeh@db.org>
* Version 0.4.19
diff --git a/include/baresip.h b/include/baresip.h
index 22c75ea..0f2dc81 100644
--- a/include/baresip.h
+++ b/include/baresip.h
@@ -13,7 +13,7 @@ extern "C" {
/** Defines the Baresip version string */
-#define BARESIP_VERSION "0.4.19"
+#define BARESIP_VERSION "0.4.20"
#ifndef NET_MAX_NS
diff --git a/mk/Doxyfile b/mk/Doxyfile
index bc393ba..840f0a0 100644
--- a/mk/Doxyfile
+++ b/mk/Doxyfile
@@ -4,7 +4,7 @@
# Project related configuration options
#---------------------------------------------------------------------------
PROJECT_NAME = baresip
-PROJECT_NUMBER = 0.4.19
+PROJECT_NUMBER = 0.4.20
OUTPUT_DIRECTORY = ../baresip-dox
CREATE_SUBDIRS = NO
OUTPUT_LANGUAGE = English
diff --git a/rpm/baresip.spec b/rpm/baresip.spec
index 7504ffa..f23e52a 100644
--- a/rpm/baresip.spec
+++ b/rpm/baresip.spec
@@ -1,5 +1,5 @@
%define name baresip
-%define ver 0.4.19
+%define ver 0.4.20
%define rel 1
Summary: Modular SIP useragent