summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred E. Heggestad <alfred.heggestad@gmail.com>2017-06-23 21:05:02 +0200
committerAlfred E. Heggestad <alfred.heggestad@gmail.com>2017-06-23 21:05:02 +0200
commit5fc916c6648a5895e3631d4f4b4f3cb31b50394b (patch)
tree42e2a386d046eff850a26093fd1ee0f5f554dd1d
parentac510eac6d39c7d3244d6c8b08bc5fb22a147b6b (diff)
release version 0.5.4
-rw-r--r--Makefile2
-rw-r--r--debian/changelog6
-rw-r--r--debian/control4
-rw-r--r--docs/ChangeLog41
-rw-r--r--include/baresip.h2
-rw-r--r--mk/Doxyfile2
-rw-r--r--rpm/baresip.spec2
7 files changed, 53 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 10e3393..3072b03 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@
USE_VIDEO := 1
PROJECT := baresip
-VERSION := 0.5.3
+VERSION := 0.5.4
DESCR := "Baresip is a modular SIP User-Agent with audio and video support"
# Verbose and silent build modes
diff --git a/debian/changelog b/debian/changelog
index 369fba7..392aaed 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+baresip (0.5.4) unstable; urgency=medium
+
+ * version 0.5.4
+
+ -- Alfred E. Heggestad <alfred.heggestad@gmail.com> Sat, 24 Jun 2017 12:00:00 +0200
+
baresip (0.5.3) unstable; urgency=medium
* version 0.5.3
diff --git a/debian/control b/debian/control
index 55122ab..271927d 100644
--- a/debian/control
+++ b/debian/control
@@ -3,12 +3,12 @@ Section: comm
Priority: optional
Maintainer: Alfred E. Heggestad <aeh@db.org>
Standards-Version: 3.9.5
-Build-Depends: debhelper (>= 9.20120311), librem-dev (>= 0.5.0), libre-dev (>= 0.5.3), libasound2-dev, libavformat-dev, libavdevice-dev, libswscale-dev
+Build-Depends: debhelper (>= 9.20120311), librem-dev (>= 0.5.0), libre-dev (>= 0.5.4), libasound2-dev, libavformat-dev, libavdevice-dev, libswscale-dev
Homepage: http://www.creytiv.com/
Package: baresip
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, librem (>= 0.5.0), libre (>= 0.5.3)
+Depends: ${shlibs:Depends}, ${misc:Depends}, librem (>= 0.5.0), libre (>= 0.5.4)
Description: Modular SIP User-Agent with audio and video support
Design goals:
.
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 37e3a87..1668166 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,44 @@
+2017-06-24 Alfred E. Heggestad <alfred.heggestad@gmail.com>
+
+ * Version 0.5.4
+
+ * GIT URL: https://github.com/alfredh/baresip.git
+ * GIT tag: v0.5.4
+ * NOTE: Requires libre v0.5.4 or later
+ Requires librem v0.5.0 or later
+
+ * config:
+ - audio_level yes|no Enable audio level RTP extension
+
+ * baresip-core:
+ - add support for Client-to-Mixer Audio Level Indication (RFC 6464)
+ - add support for RTP Header Extensions (RFC 5285)
+ - module: dont load same static module twice
+ - ua: add ua_progress()
+ - ua: check for Accept header in incoming OPTIONS request
+ - use a dummy RTP port for incoming OPTIONS (ref #265)
+ - vidcodec: make the API re-entrant
+ - vidfilt: make the API re-entrant
+ - vidisp: make the API re-entrant
+ - vidsrc: make the API re-entrant
+
+ * selftest:
+ - add test for audio level indication in call
+ - add test for call progress
+
+ * Modules:
+
+ * (all video modules updated with API-changes)
+
+ * zrtp: check for RTP packet in send handler (ref #262)
+ (thanks to MobiSciLab for reporting the bug)
+
+ - registered zrtp_log function with zrtp engine
+ - improved info message on how to verify remote peer
+ - improved setting and printing of zrtp cache file
+ (thanks Juha Heinanen)
+
+
2017-05-14 Alfred E. Heggestad <alfred.heggestad@gmail.com>
* Version 0.5.3
diff --git a/include/baresip.h b/include/baresip.h
index 0c1a225..d26d0cc 100644
--- a/include/baresip.h
+++ b/include/baresip.h
@@ -13,7 +13,7 @@ extern "C" {
/** Defines the Baresip version string */
-#define BARESIP_VERSION "0.5.3"
+#define BARESIP_VERSION "0.5.4"
#ifndef NET_MAX_NS
diff --git a/mk/Doxyfile b/mk/Doxyfile
index 74065b4..fdef302 100644
--- a/mk/Doxyfile
+++ b/mk/Doxyfile
@@ -4,7 +4,7 @@
# Project related configuration options
#---------------------------------------------------------------------------
PROJECT_NAME = baresip
-PROJECT_NUMBER = 0.5.3
+PROJECT_NUMBER = 0.5.4
OUTPUT_DIRECTORY = ../baresip-dox
CREATE_SUBDIRS = NO
OUTPUT_LANGUAGE = English
diff --git a/rpm/baresip.spec b/rpm/baresip.spec
index 66fa0a1..1f96144 100644
--- a/rpm/baresip.spec
+++ b/rpm/baresip.spec
@@ -1,5 +1,5 @@
%define name baresip
-%define ver 0.5.3
+%define ver 0.5.4
%define rel 1
Summary: Modular SIP useragent