summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@ubuntu.com>2018-01-08 22:22:59 +0530
committerJonas Smedegaard <dr@jones.dk>2018-01-08 22:22:59 +0530
commitedc500d5bf9d851366b47009741d09efc185722d (patch)
tree4394471164f1d1e4c1d720b0659d0bd835f707f6 /Makefile
parentf55ecebeead135c2159ea0b89bd1887c789802ca (diff)
Use -D_GNU_SOURCE for gcc-7 compatibility
baresip fails to build with gcc-7 because libdirectfb-dev needs to know the size of struct timespec, which is an opaque type unless we're using GNU extensions, but libre-dev sets -std=c99. Adjust cflags to enable _GNU_SOURCE. Bug-Debian: https://bugs.debian.org/872406 Last-Update: 2017-08-26 Gbp-Pq: Name 1001_gcc7_compat.patch
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7df1eae..2061e9e 100644
--- a/Makefile
+++ b/Makefile
@@ -49,6 +49,7 @@ endif
CFLAGS += -I. -Iinclude -I$(LIBRE_INC) -I$(SYSROOT)/include
CFLAGS += -I$(LIBREM_PATH)/include
CFLAGS += -I$(SYSROOT)/local/include/rem -I$(SYSROOT)/include/rem
+CFLAGS += -D_GNU_SOURCE
CXXFLAGS += -I. -Iinclude -I$(LIBRE_INC)
CXXFLAGS += -I$(LIBREM_PATH)/include