summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorVasudev Kamath <kamathvasudev@gmail.com>2016-02-08 22:35:19 +0530
committerVasudev Kamath <kamathvasudev@gmail.com>2016-02-08 22:35:19 +0530
commit11c16c12a00a0aa9cf9959b2da457b6d281aca44 (patch)
treed7836b98c07e22f566cba5df608b98ca106ee955 /debian/patches
parentd8385631cc760ee5385c92bee21357a6c09aed03 (diff)
Add patch to unhide the build rules
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/2002_unhide_build_rules.patch66
-rw-r--r--debian/patches/series1
2 files changed, 67 insertions, 0 deletions
diff --git a/debian/patches/2002_unhide_build_rules.patch b/debian/patches/2002_unhide_build_rules.patch
new file mode 100644
index 0000000..1a45eeb
--- /dev/null
+++ b/debian/patches/2002_unhide_build_rules.patch
@@ -0,0 +1,66 @@
+Description: Unhide the build rules
+ Upstream hides the build rule using "@" prefix in
+ Makefile. Unhiding is needed so that blhc can check
+ for problems in building.
+Author: Vasudev Kamath <vasudev@copyninja.info>
+Last-Update: 2016-02-08
+
+--- baresip-0.4.15.orig/Makefile
++++ baresip-0.4.15/Makefile
+@@ -153,24 +153,21 @@ Makefile: mk/*.mk $(MOD_MK) $(LIBRE_MK)
+
+
+ $(SHARED): $(LIB_OBJS)
+- @echo " LD $@"
+- @$(LD) $(LFLAGS) $(SH_LFLAGS) $^ -lre $(LIBS) -o $@
++ $(LD) $(LFLAGS) $(SH_LFLAGS) $^ -lre $(LIBS) -o $@
+
+ $(STATICLIB): $(LIB_OBJS)
+- @echo " AR $@"
+- @rm -f $@; $(AR) $(AFLAGS) $@ $^
++ rm -f $@; $(AR) $(AFLAGS) $@ $^
+ ifneq ($(RANLIB),)
+- @echo " RANLIB $@"
+- @$(RANLIB) $@
++ $(RANLIB) $@
+ endif
+
+ # GPROF requires static linking
+ $(BIN): $(APP_OBJS)
+ @echo " LD $@"
+ ifneq ($(GPROF),)
+- @$(LD) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
++ $(LD) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
+ else
+- @$(LD) $(LFLAGS) $(APP_LFLAGS) $^ -lre $(LIBS) -o $@
++ $(LD) $(LFLAGS) $(APP_LFLAGS) $^ -lre $(LIBS) -o $@
+ endif
+
+
+@@ -178,22 +175,18 @@ endif
+ test: $(TEST_BIN)
+
+ $(TEST_BIN): $(STATICLIB) $(TEST_OBJS)
+- @echo " LD $@"
+- @$(LD) $(LFLAGS) $(TEST_OBJS) \
++ $(LD) $(LFLAGS) $(TEST_OBJS) \
+ -L. \
+ -l$(PROJECT) -lre $(LIBS) -o $@
+
+ $(BUILD)/%.o: %.c $(BUILD) Makefile $(APP_MK)
+- @echo " CC $@"
+- @$(CC) $(CFLAGS) -c $< -o $@ $(DFLAGS)
++ $(CC) $(CFLAGS) -c $< -o $@ $(DFLAGS)
+
+ $(BUILD)/%.o: %.m $(BUILD) Makefile $(APP_MK)
+- @echo " OC $@"
+- @$(CC) $(CFLAGS) $(OBJCFLAGS) -c $< -o $@ $(DFLAGS)
++ $(CC) $(CFLAGS) $(OBJCFLAGS) -c $< -o $@ $(DFLAGS)
+
+ $(BUILD)/%.o: %.S $(BUILD) Makefile $(APP_MK)
+- @echo " AS $@"
+- @$(CC) $(CFLAGS) -c $< -o $@ $(DFLAGS)
++ $(CC) $(CFLAGS) -c $< -o $@ $(DFLAGS)
+
+ $(BUILD): Makefile
+ @mkdir -p $(BUILD)/src $(MOD_BLD) $(BUILD)/test
diff --git a/debian/patches/series b/debian/patches/series
index 7440c68..dd1b152 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
2001_drop_libre_so_check.patch
+2002_unhide_build_rules.patch