summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorVasudev Kamath <kamathvasudev@gmail.com>2016-02-08 22:24:32 +0530
committerVasudev Kamath <kamathvasudev@gmail.com>2016-02-08 22:24:32 +0530
commit462ab8c3c30252b190b048b62ba7b3639ce58b7e (patch)
tree1f0f2b4f67f90e32fdcc88415549645a305fecd9 /debian/patches
parent319c9c214f23101c5e1647874b20cd3aee4d8901 (diff)
Introduce patch to ignore LIBRE_SO
LIBE_SO setting is not really mandatory for package builds because library will be in system path.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/2001_drop_libre_so_check.patch48
-rw-r--r--debian/patches/series1
2 files changed, 49 insertions, 0 deletions
diff --git a/debian/patches/2001_drop_libre_so_check.patch b/debian/patches/2001_drop_libre_so_check.patch
new file mode 100644
index 0000000..455ba29
--- /dev/null
+++ b/debian/patches/2001_drop_libre_so_check.patch
@@ -0,0 +1,48 @@
+Description: Drop checking for LIBRE_SO for empty
+ LIBRE_SO variable holds path for libre.so library.
+ This is not really required for package builds as
+ ld will search system paths for library.
+ .
+ This patch might not be suitable for upstream though.
+Author: Vasudev Kamath <vasudev@copyninja.info>
+Last-Update: 2016-02-08
+
+--- a/Makefile
++++ b/Makefile
+@@ -148,17 +148,13 @@
+ @echo "ERROR: Missing header files for libre. Check LIBRE_INC"
+ @exit 2
+ endif
+-ifeq ($(LIBRE_SO),)
+- @echo "ERROR: Missing library files for libre. Check LIBRE_SO"
+- @exit 2
+-endif
+
+ Makefile: mk/*.mk $(MOD_MK) $(LIBRE_MK)
+
+
+ $(SHARED): $(LIB_OBJS)
+ @echo " LD $@"
+- @$(LD) $(LFLAGS) $(SH_LFLAGS) $^ -L$(LIBRE_SO) -lre $(LIBS) -o $@
++ @$(LD) $(LFLAGS) $(SH_LFLAGS) $^ -lre $(LIBS) -o $@
+
+ $(STATICLIB): $(LIB_OBJS)
+ @echo " AR $@"
+@@ -174,7 +170,7 @@
+ ifneq ($(GPROF),)
+ @$(LD) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
+ else
+- @$(LD) $(LFLAGS) $(APP_LFLAGS) $^ -L$(LIBRE_SO) -lre $(LIBS) -o $@
++ @$(LD) $(LFLAGS) $(APP_LFLAGS) $^ -lre $(LIBS) -o $@
+ endif
+
+
+@@ -184,7 +180,7 @@
+ $(TEST_BIN): $(STATICLIB) $(TEST_OBJS)
+ @echo " LD $@"
+ @$(LD) $(LFLAGS) $(TEST_OBJS) \
+- -L$(LIBRE_SO) -L. \
++ -L. \
+ -l$(PROJECT) -lre $(LIBS) -o $@
+
+ $(BUILD)/%.o: %.c $(BUILD) Makefile $(APP_MK)
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..7440c68
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+2001_drop_libre_so_check.patch