summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2016-12-28 00:07:22 +0100
committerJonas Smedegaard <dr@jones.dk>2016-12-28 00:07:22 +0100
commit9214a724808e07d9a891512fee95dcfb9da0a1df (patch)
tree9b7c33674b1ee1b687ab57ee430b9569b1f59161 /debian/rules
parente8417f85e120340700610212a74d0c11d019fcd0 (diff)
Simplify build: Drop build flags equal to auto-resolved defaults.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 1 insertions, 24 deletions
diff --git a/debian/rules b/debian/rules
index e8b81e2..b608f17 100755
--- a/debian/rules
+++ b/debian/rules
@@ -51,30 +51,7 @@ LIBDIR=/usr/lib
# TODO: Drop when makefiles.mk can handle the package
common-build-arch common-build-indep:: build_rem_package
build_rem_package:
- make info all RELEASE=1 \
- V=1 \
- PREFIX=/usr/ \
- USE_OPENSSL=1 \
- USE_ZLIB=1 \
- USE_TLS=1 \
- USE_VIDEO=1 \
- USE_ALSA=1 \
- USE_AMR=1 \
- USE_AVCODEC=1 \
- USE_AVFORMAT=1 \
- USE_CAIRO=1 \
- USE_X11=1 \
- USE_MPG123=1 \
- USE_CONS=1 \
- USE_EVDEV=1 \
- USE_G711=1 \
- USE_G722=1 \
- USE_GSM=1 \
- USE_GST1=1 \
- USE_GST_VIDEO1=1 \
- USE_VP8=1 \
- USE_VP9=1 \
- USE_OPUS=1 \
+ make info all V=1 PREFIX=/usr RELEASE=1 \
EXTRA_CFLAGS="$(CFLAGS) $(CPPFLAGS)" \
EXTRA_LFLAGS="$(LDFLAGS)" \
EXTRA_MODULES="$(EXTRA_MODULES)"